Jump to content

Secure Browser Warning


Recommended Posts

Hello.  This morning, I logged into ESET PROTECT and several of our PCs have the warning ""Secure Browser is non-functional".  I checked and we don't even have Secure Browser active, and to be honest, I didn't even know it was an option.  We are running ESET PROTECT (Server), Version 8.0 (8.0.1258.0) and ESET PROTECT (Web Console), Version 8.0 (8.0.191.0) with ESET Management Agent 8.0.1238.0 and ESET Endpoint Security 8.0.2028.0.  Any ideas on why we are seeing this now and how to turn off these warnings?  Thanks!
 

Capture.JPG

Link to comment
Share on other sites

It looks like rebooting the PC clears the warning, but it would be nice to know why it's just now coming up and if there was a way to fix this without having to reboot the PC.

Link to comment
Share on other sites

  • ESET Staff

Hello,

Secure browser is a new functionality that was added in V8 Endpoint: https://help.eset.com/ees/8/en-US/solving_problems_protocol_filtering.html?whats_new.html

You can disable secure browser via policy from ESET PROTECT: https://help.eset.com/ees/8/en-US/solving_problems_protocol_filtering.html?idh_config_sb.html 

Most likely, this might be related to either fact that your endpoint was recently updated, or your computer was recently updated. We might need more details (logs from client) to investigate, but for that, a customer care ticket is recommended. 

Link to comment
Share on other sites

Hello.  It looks like Secure Browser is already disabled and all of our clients have been running ESET Endpoint Security 8.0.2028.0 about a week after it was released.  It's possible the PC was updated with updates like Chrome, Firefox, etc, but nothing Windows Update related since those are all controlled.  I can look into creating a new ticket to see if they need logs to investigate.  Thanks.Capture.thumb.JPG.f7487985a47f774ed4583a0672606908.JPG 

Capture1.JPG

Link to comment
Share on other sites

  • ESET Staff

Please note, that if the screenshot from your policy, secure browser is actually not set by the policy. You will have to click on the full circle to apply the setting. 

Currently, even though the switch is in "disabled" state, it does not affect the endpoint behavior, meaning if the user enabled it locally (for example if having admin rights), that might have triggered the "non functional" error locally. 

Your policy should look like this: 

disable browser.png

Link to comment
Share on other sites

Ok, I changed my policy so that Secure Browser is disabled.  I don't think our users would have turned it on since the PCs that have this warning, the users do not have admin rights.  Thanks for the help.

Link to comment
Share on other sites

Hello.  After changing the Secure Browser policy to disabled and preventing changes to the policy, I rebooted all of our PCs on Monday.  Yesterday, no PCs were showing this warning in ESET PROTECT, but today, about half of my PCs are showing this warning again.  I submitted a case with ESET to see how we can fix this issue/bug.

Link to comment
Share on other sites

  • Administrators

It's caused by a bug in an internal notification system triggered by installation of a new version of the eelam driver by a module that is being gradually released in batches. The bug in the internal notification system will be fixed in the next Endpoint v8. Rebooting the machine should clear the notification.

Link to comment
Share on other sites

  • Administrators
7 minutes ago, conorc said:

I am also seeing this issue with our devices.

A computer restart should clear the notification.

Link to comment
Share on other sites

Is there any way to force the update through? I'm experiencing this on a stateless VDI setup, but the template VM remains steadfastly on the 10.0.12.0 eelam.sys driver after repeated update checks, while the composed VMs are intermittently getting the 10.0.13.0 build and the warning state since Monday.

Link to comment
Share on other sites

  • Administrators

Right now you can force module update by switching to the pre-release update channel in the update setup or wait a few more days until all computers receive it automatically from the standard release update channel.

On clients where the driver / module has been updated, the notification should be cleared after a computer restart.

Link to comment
Share on other sites

Thanks, pre-release channel did it. 🙂 Trouble with stateless VDI for this, a reboot only temporarily clears the notification since reboots also cause the update to revert back to the template state. Got to make changes to the template VM for them to stick.

Link to comment
Share on other sites

I have the same issue too and my PC's that are affected can't be rebooted right now. (Their next reboot window is early next month.) Will this issue affect any other functionality? Thanks.

Link to comment
Share on other sites

  • Administrators
7 hours ago, FRiC said:

I have the same issue too and my PC's that are affected can't be rebooted right now. (Their next reboot window is early next month.) Will this issue affect any other functionality? Thanks.

It doesn't affect any functionality, it's just a minor bug in internal reporting. However, you can suppress the notification by disabling it in the application statuses setup:

image.png

The first check will suppress it on the client while the other (Send) will suppress it in the ESET PROTECT console.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...