Jump to content

export settings not exported correctly


Recommended Posts

  • Most Valued Members

I did a clean install of ess (using the uninstaller at safe mode) and after setting up depending on my needs, I went to export the settings.

half of the settings are not exported as meant and they are missing from the XML file.

 

I compared the old and the new XML settings file using notepad++.

 

I've encountered this issue for years and several versions.

export settings will not be exported 100%

 

 

 

EDIT.

I want to add that after going through the settings again, I saw that most of them didn't save upon pressing OK during my initial setup.

I change the settings I want to change, press OK, open the settings panel again, and they are back to default and not saved.

Edited by pavilion_alex
Link to comment
Share on other sites

So maybe your real issue is that your settings aren't saved correctly?

(And of course if they aren't saved correctly then they can't be exported correctly...)

 

So what OS and ESS version are you using and were you using the same for importing and exporting or did you exported the configuration of an older version and imported?

And additionally it would be nice if you could explain which .xml you exported at what time and with which product version if they were different.

 

As I see the new.xml is quite like default settings, expect of the "<SCANNER ID="0">" part which includes some basically scanner settings.

old.xml seems to be configured much more, so why don't just import old.xml?

 

But back to the settings saving issue: Can you reproduce this so happens it every time you save settings or if not under what circumstances does it happen?

Additionally can you save the settings correctly if you restart ESS with admin rights?

Link to comment
Share on other sites

  • Most Valued Members

my OS is win 8.1 32bit, ESS 8.0.312.0.

 

i was using the same version i mention.

 

the main issue is this, even after a clean install (from safe mode with the uninstaller tool), when I configure the settings i notice in settings > computer > on-demand computer scan > threatsense setup > objects. most of them won't be saved after clicking OK on all windows and open them again, the checkboxes will be blank again.

 

I have to double and triple check/set them in order to be saved again. so I guess this is why most of them won't be saved on the xml in the beginning.

 

the old xml was the one i had managed to export when all settings were exactly as i wanted them.

the new was right after configuring the settings for the first time after the completion of the installation.

 

the location i select to save them is in the Documents folder. i will try to use the uninstaller in safe mode and start again with SS in admin rights and report later.

Link to comment
Share on other sites

  • Most Valued Members

so I started from scratch and i have several xml files.

the file with the number 2 is the second attempt to save a new file with the settings.

even with admin rights I noticed that some of them didn't stay as I set them.

 

I selected to save them on the desktop.

settings after starting program with admin rights (2).xml

settings after starting program with admin rights.xml

settings right after installation.xml

Link to comment
Share on other sites

Okay so the fact that the settings are not saved correctly is of course unwanted.

As for all files there are not really any differences, in "settings after starting program with admin rights.xml" there is piratically nothing changed and in "settings after starting program with admin rights (2).xml" a bit more is added.

 

But of course we need to know what settings you intended to change. (You can of course test some setting and so on...)

So does it only happen to "settings > computer > on-demand computer scan > threatsense setup > objects"? BTW there you of course also have multiple profiles so does it happen with every profile?

And what happens if you for instance create new profile there with some customized settings?

 

And BTW can you import settings successfully? (For example try it with these ones: Block OpenCandy :D)

Link to comment
Share on other sites

  • Most Valued Members

what do you mean with multiple profiles?

I am able to import my already exported settings without an issue, when I managed to export a file with all the settings I wanted.

 

the example I gave earlier it was just one of the part of settings I see they don't get saved.

Edited by pavilion_alex
Link to comment
Share on other sites

  • Administrators

Please provide a short list of settings that you saved but were not subsequently imported.

Link to comment
Share on other sites

  • Most Valued Members

during older unin/installations I had no problem to successfully import the settings.

my main concern is after initial setup I must check twice the settings I want to change because they won't be saved.

 

the affected areas are

real-time file system protection > threatsense setup

on-demand computer scan > threatsense engine

document protection > setup

update > settings > setup > regularly check for....

update > update rollback (it won't remember the number I set until I set it 2nd or 3rd time)

 

in the subcategories of "objects", "options" and "other"

 

in these areas settings won't persist after changing them for the first time and I must do it again.

Edited by pavilion_alex
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...