Jump to content

Unable to install ERAS 6 on CentOS


Sarvesh Singh
 Share

Recommended Posts

We are trying to install ERA server in CentOS 6.5 but unable to do.
We have successfully installed the WebConsole as instructed in help.eset.com after that we started the installation of MySQL and we have installed 5.7 but service is unable to start getting error "mysql daemon failed to start" Check MySQL logs attached. so the ERAS is unable to make communication with MySQL database.
We have reinstalled MySQL with community release 5.7 but the same issue. also followed forum hxxp://www.tecmint.com/install-latest-mysql-on-rhel-centos-and-fedora/but the issue is same.

Logs attached: system info from get command, mysql error file.

Linux_CentOS_issue.rar

Link to comment
Share on other sites

  • ESET Staff

We are trying to install ERA server in CentOS 6.5 but unable to do.

We have successfully installed the WebConsole as instructed in help.eset.com after that we started the installation of MySQL and we have installed 5.7 but service is unable to start getting error "mysql daemon failed to start" Check MySQL logs attached. so the ERAS is unable to make communication with MySQL database.

We have reinstalled MySQL with community release 5.7 but the same issue. also followed forum hxxp://www.tecmint.com/install-latest-mysql-on-rhel-centos-and-fedora/but the issue is same.

Logs attached: system info from get command, mysql error file.

 

Hello,

 

wee are currently using community MySQL 5.6 in our CentOS-based appliances and have not encountered any problem. Could you please check this: https://www.centos.org/forums/viewtopic.php?f=14&t=44526&start=20... seems it is almost the same problem.

Link to comment
Share on other sites

Hey, @MartinK, I've been trying to resolve an issue with PDF report generation on my CentOS ERAS. According to the Installation docs:

 

"

Qt4 WebKit libraries - Used for printing reports to PDF and PS format (must be version 4.8, not 5). All other Qt4 dependencies will be installed automatically.

validation-status-icon-info.pngNOTE: In the case of CentOS, there may be no package in the official repositories. You can install it from a third-party repository (for example EPEL repositories) or compile it yourself on a target machine.

 

"

 

However, I've been having a really hard time hunt down the Qt4 WebKit libraries that are compatible. I've added the EPEL repositories but the only installed version I have is 2.1. At most, I've managed to tweak the libraries by hand to successfully perform .CSV generation, but PDF and PS formats fail every time.

 

Do you have an unofficial "ESET-supported" third-party rpm I can pull from ?

Link to comment
Share on other sites

  • ESET Staff

Hey, @MartinK, I've been trying to resolve an issue with PDF report generation on my CentOS ERAS. According to the Installation docs:

 

"

Qt4 WebKit libraries - Used for printing reports to PDF and PS format (must be version 4.8, not 5). All other Qt4 dependencies will be installed automatically.

validation-status-icon-info.pngNOTE: In the case of CentOS, there may be no package in the official repositories. You can install it from a third-party repository (for example EPEL repositories) or compile it yourself on a target machine.

 

"

 

However, I've been having a really hard time hunt down the Qt4 WebKit libraries that are compatible. I've added the EPEL repositories but the only installed version I have is 2.1. At most, I've managed to tweak the libraries by hand to successfully perform .CSV generation, but PDF and PS formats fail every time.

 

Do you have an unofficial "ESET-supported" third-party rpm I can pull from ?

 

Hello,

 

you are using CentOS 6 if I recall correctly. In that case I would suggest to use Qt4 libraries we are providing in ERA appliances. You will find compiled libraries in /root directory (there should be two archives, one containing binaries and one vanilla source code it was compiled from). They are compiled specifically for this system and are using almost newest version of 4.8 branch - and of course they are tested ...

Link to comment
Share on other sites

Thanks for the fast response. You are correct, I am using 6.5, but I am not using the ERA Appliance. I installed and configured the components by hand using the .iso. Hence, my difficulty locating the 4.8 Qt4 libraries...

 

 

Link to comment
Share on other sites

  • ESET Staff

Thanks for the fast response. You are correct, I am using 6.5, but I am not using the ERA Appliance. I installed and configured the components by hand using the .iso. Hence, my difficulty locating the 4.8 Qt4 libraries...

 

I still think your best choice is to download ERA appliance, import in into Virtualbox/VMWare and copy-out those libraries even before configuration is required :ph34r:

Link to comment
Share on other sites

 

We are trying to install ERA server in CentOS 6.5 but unable to do.

We have successfully installed the WebConsole as instructed in help.eset.com after that we started the installation of MySQL and we have installed 5.7 but service is unable to start getting error "mysql daemon failed to start" Check MySQL logs attached. so the ERAS is unable to make communication with MySQL database.

We have reinstalled MySQL with community release 5.7 but the same issue. also followed forum hxxp://www.tecmint.com/install-latest-mysql-on-rhel-centos-and-fedora/but the issue is same.

Logs attached: system info from get command, mysql error file.

 

Hello,

 

wee are currently using community MySQL 5.6 in our CentOS-based appliances and have not encountered any problem. Could you please check this: https://www.centos.org/forums/viewtopic.php?f=14&t=44526&start=20... seems it is almost the same problem.

 

I already tried the setting given on the link but the issue is same.

Link to comment
Share on other sites

  • ESET Staff

 

 

We are trying to install ERA server in CentOS 6.5 but unable to do.

We have successfully installed the WebConsole as instructed in help.eset.com after that we started the installation of MySQL and we have installed 5.7 but service is unable to start getting error "mysql daemon failed to start" Check MySQL logs attached. so the ERAS is unable to make communication with MySQL database.

We have reinstalled MySQL with community release 5.7 but the same issue. also followed forum hxxp://www.tecmint.com/install-latest-mysql-on-rhel-centos-and-fedora/but the issue is same.

Logs attached: system info from get command, mysql error file.

 

Hello,

 

wee are currently using community MySQL 5.6 in our CentOS-based appliances and have not encountered any problem. Could you please check this: https://www.centos.org/forums/viewtopic.php?f=14&t=44526&start=20... seems it is almost the same problem.

 

I already tried the setting given on the link but the issue is same.

 

 

It is quiet hard to guess where problem is. Have you tried to run /usr/sbin/mysqld manually? Maybe it will print more detailed error. There are many alternatives .. maybe insufficient system resources, missing file permissions, missing dependencies (maybe some module cannot be loaded due to missing library).

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...