Jump to content

Search the Community

Showing results for tags 'database'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • ESET General Forums
    • ESET Announcements
    • General Discussion
    • Forum FAQ's and Rules
    • Submit a virus, website or potential false positive sample to the ESET lab
    • Quick questions by guests (registration not required)
    • WeLiveSecurity.com
  • ESET Home User Products
    • ESET Internet Security & ESET Smart Security Premium
    • ESET NOD32 Antivirus
    • ESET Cyber Security (for Mac)
    • ESET Cyber Security Pro (for Mac)
    • ESET NOD32 Antivirus for Linux Desktop
    • ESET Products for Mobile Devices
    • Web portals
  • Malware Detection and Cleaning
    • Malware Finding and Cleaning
    • ESET Standalone Malware Removal Tools
  • ESET Business User Products
    • ESET Cloud solutions
    • ESET Endpoint Products
    • ESET Products for Windows Servers
    • ESET Products for Linux Servers
    • ESET Products for Mobile Devices
    • Remote Management
    • ESET Enterprise Inspector (EDR)
    • ESET Products for Virtualized Environments
    • Encryption
    • ESET Licensing for Business
    • Other ESET business products
  • ESET Beta Products
    • ESET Beta Products for Home Users
    • ESET Beta Products for Business Users
  • Slovak and Czech forums
    • ESET NOD32 Antivirus, ESET Internet Security a ESET Smart Security Premium
    • Produkty pre mobilné zariadenia
    • Vírusy a iné hrozby
    • Ostatné

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests

Found 22 results

  1. Hello. I have ESMC v7.2.1266.0 running with Microsoft SQL Server 2017 (RT Express Edition (64-bit) v14.0.2027.2. I'm doing some maintenance in our environment and I see that SQL Server 2017 CU21 was released on 7/1/2020. The version I'm running (v14.0.2027.2) was released 7/9/2019. My question is am I able to upgrade our SQL to CU21 without causing any major issues with ESET? I believe it should be okay, but I wanted to see if anyone else has upgraded their DB or if the version of ESMC has be using SQL v14.0.2027.2. Thanks! https://support.microsoft.com/en-us/help/4047329 https://support.microsoft.com/en-us/help/4557397/cumulative-update-21-for-sql-server-2017
  2. Hello, Is there any option, tool or maintenace task to decrease the database of the ERA v6. It has inside hundreds of thousands unneeded logs and I want to get rid of them. Era version is 6.5 & database is MSSQL Express. Thanks, Peter
  3. I have the Eset ERA server 5.2.26 on the Windows Server 2008 R2. I would like to upgrade the ERA version to 6 using the Migration tool. I had installed all prerequisities (C++ and MS Hotfix) and would like to export database 5.2.26 via migration tool. After choosing the export database check box and click on the Next buton, there are the error message "Unable to stop RemoteAdministrator service". I tried to stop it via the ERA maintenance tool, it works, but after the choosing what data could be exported there was next error message - cannot connect to database. Have you any idea? Thank you.
  4. Hola tengo el inconveniente on el archivo tempdb de de la base de datos que se llena ocupando gran parte del disco y me genera problemas con la consola y con las actualizaciones y toca estar reiniciando el servidor para liberar el tempdb pero de igual manera se va incrementando llenando el disco.
  5. Dear All, I facing problem while login to ERA Web Console. As I have checked, ERA Server service & ERASQL service has been stooped. And we are unable to start the ERASQL service, error code is 3417. Please find attached screen shot and help me. Thank You.
  6. Hello Team how to backup era 6.3/6.4 include agent connection & policy with database? Regards Vimarsh P.
  7. Hello, trying to create a new Annual report with chart including the following: Active Threats report Threats Resolved Threats Unresolved But there are some issues cretating this report. Anyone may help or to propose current or create a new report with the above topics? Thanks in advance, Vasilis
  8. Hi all, We are actually deploying the ERA 6 server on our Linux Debian 7.8 server to manage our licenses but we do have some troubles. The ERA server and Web console have been installed succesfully. By that we mean that installation has ended without any problem and that we can use the web console (and generate the needed certificates). But next step is to setup an agent on the server itself (as it seems to be needed), and that's were we actually do have problems. From web console we donwloaded the "Agent Certificate" and the "Certificate Authority Public Key" that were generated at server installation (those that are allready listed). Then we just run following Agent-Setup command specifying the agent certificate and CA public Key: ./Agent-Linux-x86_64.sh \ --skip-license \ --cert-path="/PATH/Certificate Export CN=Agent at _ C=US.pfx" \ --cert-auth-path="/PATH/Certification Authority CN=Server Certification Authority C=US public key.der" \ --cert-password= \ --hostname=SERVERIP \ --port=2222 Note, the pre-generated Agent Cert has no password, therefore we leave the password field blank. But the installation fails with following error: Database status is 'DB_INVALID'. Database cannot be upgraded, because it is corrupted or it is not ERA database. Searching through log file, those are the last lines: 2015-03-04 10:37:23 Information: Installer: Reading database status... 2015-03-04 10:37:23 Information: DbCheckStatus: Action invoked with: --cert-auth-content "" --cert-auth-path /PATH/Certification Authority CN=Server Certification Authority C=US public key.der --cert-auth-temp-path "" --cert-content "" --cert-password ********** --cert-path /PATH/Certificate Export CN=Agent at _ C=US.pfx --cert-temp-path "" --cert-to-check-password ********** --cert-to-check-path /PATH/Certificate Export CN=Agent at _ C=US.pfx --computer-added-uuid "" --computer-group-choice DEFAULT --connection-chosen host --current-version 6.1.450.0 --db-connectors-dir /opt/eset/RemoteAdministrator/Agent/setup --db-path /var/opt/eset/RemoteAdministrator/Agent/data.db --db-scripts-dir /opt/eset/RemoteAdministrator/Agent/setup/Database --db-type SQLite --db-upgrade "" --era-lib-dir /opt/eset/RemoteAdministrator/Agent/ --hostname SERVERIP --installed-version 6.1.450.0 --log-sequence-id "" --modules-dir /var/opt/eset/RemoteAdministrator/Agent/Modules/ --port 2222 --product-guid GUID --product-name Agent --replication-interval "" --server-cert-temp-path "" --webconsole-hostname "" --webconsole-password ********** --webconsole-port 2223 --webconsole-user Administrator 2015-03-04 10:37:23 Information: Entering function: std::string Era::Setup::Common::CustomActions::CDatabaseReader::GetDatabaseStatusForEmbeddedDB(const string&, const string&, const string&) 2015-03-04 10:37:23 Information: Entering function: std::string Era::Setup::Common::CustomActions::CDatabaseReader::GetDatabaseStatus(const string&, const string&, const string&, std::stringstream&, std::vector<std::basic_string<char> >&) 2015-03-04 10:37:23 Information: DbCheckStatus: Set output property: P_DB_STATUS = DB_INVALID 2015-03-04 10:37:23 Information: DbCheckStatus: Return code: 0 2015-03-04 10:37:23 Information: Installer: Parsed output property: arg_db_status=DB_INVALID 2015-03-04 10:37:23 Information: Installer: Database read successfully. 2015-03-04 10:37:23 Information: Installer: Database status is 'DB_INVALID' 2015-03-04 10:37:23 Information: Installer: Database status is 'DB_INVALID'. Database cannot be upgraded, because it is corrupted or it is not ERA database. As we can see there seems to be a problem with the database... But which one ? Regarding following line in the logs, we assume that the Agent has its own database (an sqlite one): --db-type SQLite But we have no idea on what to do to debug this situation... If someone has any idea or steps to find out what is wrong here, we would be very pleased. Best regards, G.
  9. Hi guys, We have issues with our ERA. The service SQL Server Agent (ERASQL) is starting for 1second and then stops again. And after that it won't start at all. What we have tried: - Repair SQL server - Repair the ESET install - Starting and stopping all SQL services - Running the service under different users ( local admin and a created user with admin rights etc.) Does anyone know a fix for this ?
  10. Hello Eset How To Create Full Backup Of Era Server 6.3 Please tell me step by step.. Thanks & Regards Vimarsh Panchal
  11. Hi, I am having issues installing the ESET Remote Administrator Agent on clients workstations and server. The issue is that 1) when running the .bat installer it fails with erro 1603 even though I am logged in as domain administrator and running it as administrator. So I installed it on my local machine and copied the msi file to our clients machines. Upon executing (as domain admin and running it as administrator)2) I am getting an error where the database cannot be upgraded and that the product has to be uinistalled. I can find no trace of this database on this machine. Any one know how to resolve this? Matthew
  12. Hello team, We are facing an issue with the Migration from 5.x to 6.x - Unable to export from Migration tool. I have already installed the ESET V6.3 on the new server and im able to login to web console. Now the migration process is in progress where I’m unable to export old database from the old server using the migration tool. PF below link where we are facing the same issues. https://forum.eset.com/topic/6748-migration-from-5x-to-6x-unable-to-export-old-database/?hl=migration+tool And if I manually stop the Remote Administrator Service and continue, the next error is the same as the link below https://forum.eset.com/topic/5681-era-5-migrating-to-era-6-migration-error/?hl=migration+tool#entry32447
  13. When attempting to upgrade using the instructions here on CentOS: hxxp://support.eset.com/kb3670/, specifically step 9: Run the ERA Server installer: ./Server-Linux-x86_64.sh --skip-license Extracting archive, please wait... Archive extracted to /tmp/tmp.lK8FpNVE9q. Checking OpenSSL ... done [OpenSSL 1.0.1e-fips 11 Feb 2013] Reading previous installation settings ..../Server-Linux-x86_64.sh: eval: line 495: unexpected EOF while looking for matching `"' ./Server-Linux-x86_64.sh: eval: line 496: syntax error: unexpected end of file ./Server-Linux-x86_64.sh: line 496: warning: syntax errors in . or eval will cause future versions of the shell to abort as Posix requires done Checking installed version... done Status of current installation is: UPGRADE Checking database connection ... failure Error: User login failed (invalid credentials provided) The log file in /var/log/eset/RemoteAdministrator/EraServerInstaller.log shows: 2016-01-27 20:19:21 Information: Exception thrown while connecting to the database as a user.. Error code: 1045, DB specific error code: 1045, error message: [unixODBC][MySQL][ODBC 5.3(w) Driver]Access denied for user 'era'@'localhost' (using password: NO) 2016-01-27 20:19:22 Information: Exception thrown while connecting to the database SERVER as a user.. Error code: 1045, DB specific error code: 1045, error message: [unixODBC][MySQL][ODBC 5.3(w) Driver]Access denied for user 'era'@'localhost' (using password: NO) It looks like the script is attempting to connect to the database and it is getting rejected as requiring a password?
  14. We are trying to install ERA server in CentOS 6.5 but unable to do. We have successfully installed the WebConsole as instructed in help.eset.com after that we started the installation of MySQL and we have installed 5.7 but service is unable to start getting error "mysql daemon failed to start" Check MySQL logs attached. so the ERAS is unable to make communication with MySQL database. We have reinstalled MySQL with community release 5.7 but the same issue. also followed forum hxxp://www.tecmint.com/install-latest-mysql-on-rhel-centos-and-fedora/but the issue is same. Logs attached: system info from get command, mysql error file. Linux_CentOS_issue.rar
  15. Hi there, So we are an IT support company using Kaseya for the bulk of our work. We have been pushing ESET for all of our clients and decided to install the ESET Remote Administrator Kaseya Plugin. It was working perfectly for a little while, but then all of a sudden stopped working and we can't figure out why. Basically even though the connection tests to the ERA servers are successful, they no longer refresh or update and the refresh in progress just sits on True. I tried uninstalling and reinstalling the plugin and reapplying the schema multiple times but had no luck. I also noticed that version 2.2 of the plugin is out so I upgraded to that one and have the same issue. Now it looks like the buttons to add/refresh/edit ERA servers have all disappeared from the webpage. I guess what I need to know is if anyone else has had this issue, and is there a way I can remove the plugin completely and reinstall it fresh? (when I uninstall and reinstall, it still has all of the data from the old installation). i have attached a picture of the ERA servers window (I have erased the IP and hostname information) where you can see that the buttons have disappeared. Any help would be appreciated! Thanks, Corey
  16. Hi, We are using Microsoft Report Builder to generate summary reports for different customers Is it possible to integrate the data from the Era Remote Administrator 6 database? And are there SQL views or queries available so I can integrate the data in our summary reports We want to know for each customer (group) the total threats last month and if scanner is up to date and top 10 system with threats etc. I hope that somebody can help
  17. Hi. We have installed eset remote administrator 6 this monday. All was fine until yesterday. We have deploy the agent on a computer but this one newer showed up on the console. We did a reboot of the server and now we can't login to the console. The server is a VM with WIndows 2012. ERA version is the latest. We can connect to the db from a distant server with the era_user and the AD domain administrator. Port 2223 is open on the server. Port 2222 is open on the server. I checked the server log and this one is full of error: 2015-10-01 06:53:50 Error: CReplicationModule [Thread 1028]: CStepProcessor: Failed to process network message of type 200 because of missing replication context 2015-10-01 06:53:51 Error: CReplicationModule [Thread 101c]: CStepProcessor: Replication master validation process failed with: Object d42ba487-bf5f-4c87-9361-9c5c7d76dd9b was not found (LoadComputer: Computer does not exist) 2015-10-01 06:53:53 Error: CReplicationModule [Thread 1024]: CStepProcessor: Replication master validation process failed with: Object d42ba487-bf5f-4c87-9361-9c5c7d76dd9b was not found (LoadComputer: Computer does not exist) 2015-10-01 06:53:55 Error: CReplicationModule [Thread 1038]: CStepProcessor: Replication master validation process failed with: Object d42ba487-bf5f-4c87-9361-9c5c7d76dd9b was not found (LoadComputer: Computer does not exist) 2015-10-01 06:53:57 Error: CReplicationModule [Thread 1034]: CStepProcessor: Replication master validation process failed with: Object d42ba487-bf5f-4c87-9361-9c5c7d76dd9b was not found (LoadComputer: Computer does not exist) 2015-10-01 06:53:59 Error: CReplicationModule [Thread 1020]: CStepProcessor: Replication master validation process failed with: Object d42ba487-bf5f-4c87-9361-9c5c7d76dd9b was not found (LoadComputer: Computer does not exist) 2015-10-01 06:54:01 Error: CReplicationModule [Thread 102c]: CStepProcessor: Replication master validation process failed with: Object d42ba487-bf5f-4c87-9361-9c5c7d76dd9b was not found (LoadComputer: Computer does not exist) Can someone help me please
  18. Looks wie still have the protoscan2 bug on our primary mirror (ERAS 5). Clear update cache seems not working. If I create a new update mirror on some of our clients, the bug is fixed there. How can I fix it in eras? THX a lot,
  19. Hi, How to update clients from era server ?? thanks.
  20. I am planning the upgrade from ERA5 to ERA6 (in a SBS2011 environment). There already is SQLServer 2008 R2 running, in fact already several instances, with backups etc, of which I intend to re-use one. However I am not all clear about the architecture. In the installation guide about SQL Server installation (and in various other places, like the specific guide about SBS), login mode is to be changed to use "mixed mode", that is both "SQL login" along with Windows authentications. Later (§3.7.1 Server installation), the connection from the server is specified to be either with login or using integrated Windows. Then at §3.7.5 Proxy installation, there is another (ODBC) connection to be created; this time there is no specification about which authentication mode to use; I guess both should be valid at this point. Since this is a small network, there is no requirement for a proxy anyway, is it? Then at §3.7.6 Mobile Connector installation, there is another database and another connection to be created, again specified to be either with login or using integrated Windows. I do not have Mobile Devices anyway, so it does not matter much. The HTTP "mirroring" proxy at §3.7.8 does not use database connection; and the web console does not seem to use it either, does it? So at the bottom of the day, it seems that I can fly with Windows authentication, and can avoid the need to create and maintain SQL logins altogether. Is there something I missed at some point?
  21. I successfully deployed 3 other ERA 6 Servers on linux with MySQL local database engine. Now I need to install Era Server 6 on 32b Linux Ubuntu 12.04 Server with database located on 64b Windows Server 2008 R2 SQL 2012. I configured ODBC under Linux and I successfully obtain connection to MS SQL Server with isql or sqsh command (with the same credentials as passed to ERA installer script). But running ERA 6 Server installation fails on 'Checking database connection ... failure'. Log file EraServerInstaller.log contains: 2015-05-07 11:18:42 Information: DbCheckConnection: Set output property: P_DB_ADMIN_CONNECTION_STATUS = 65535 2015-05-07 11:18:42 Information: ERROR: DatabaseException with error code '65535' and message - [unixODBC][FreeTDS][SQL Server]Login failed for user ''. 2015-05-07 11:18:42 Information: DbCheckConnection: Return code: 0 2015-05-07 11:18:42 Information: Installer: Admin connection check failed. Unable to continue. 2015-05-07 11:18:42 Information: Installer: Error: Admin connection not working. Unable to continue. I installed all (I hope) additional packages: unixodbc unixodbc-dev freetds-dev sqsh tdsodbc My DB related installer options are: --db-driver=FreeTDS --db-hostname=192.168.18.5 --db-port=1433 --db-admin-username=sa --db-admin-password=<my pass> My configuration files: /etc/freetds/freetds.conf: [server] host = 192.168.18.5 port = 1433 tds version = 7.0 /etc/odbcinst.ini: [FreeTDS] Description = ODBC for MS SQL Driver = /usr/lib/i386-linux-gnu/odbc/libtdsodbc.so Setup = /usr/lib/i386-linux-gnu/odbc/libtdsS.so FileUsage = 1 /etc/odbc.ini: [server] Driver = FreeTDS Description = ODBC connection via FreeTDS Trace = No Servername = server I hope there is someone who successfully deployed ERA Server with external database. Is it possible I should use different value for '--db-driver=' option ?
  22. I've been testing the ERA 6, and one problem has been a real pain in the , the repository works fine at start, but in sometime he just stops working, i reinstall the ERA and problem solved, one week later... same problem... anyone with the same problem?
×
×
  • Create New...