Jump to content
CasualUser

Repeated popups to turn on marketing messages when set to OFF in preferences already, no option to decline

Recommended Posts

Installed the current ESET Nod32 version on three computers.  First computer I manually setup my preferences for the different options.  One of which is to disable In Product Messaging - Display Marketing Messages to OFF.  I then exported these settings and for the other two systems I imported them from the file.  I verified that all settings were imported and specifically looked at the marketing setting as being off on each.  Both system popped up a message about a hour later asking if I wanted to display marketing notifications...options to click were only "Accept" or "Postpone".  Clicked postpone since there is not Decline or Off option.  checked preferences and still had marketing messages as off.  Several days later the same popup came up again.  Same "Accept" or "Postpone" options.  Clicked Accept to check if I was looking at the proper setting in the preferences.  Now the Display marketing messages was turned on.  Manually turned it off AGAIN in preferences.  How do I get this to stop asking and why isn't there an option in the popup window to Decline?  Preferences always have it disabled, so why is it even popping up repeatedly?

Had used AVG paid antivirus for years and the reason I stopped was the exact same aggressive marketing popups constantly.  Did I make a mistake trying ESET?  Please let me know how to permanently fix this to NEVER see marketing messages again.  Is my only option to turn off all messages / alerts? i paid for the program for antivirus, not to be marketed constantly for other things.

Thanks.

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, CasualUser said:

First computer I manually setup my preferences for the different options.  One of which is to disable In Product Messaging - Display Marketing Messages to OFF. 

I have the setting disabled and have exported and imported Eset settings multiple times w/o it ever being reset to the on setting.

Are these Eset installations "Trial" versions? That might explain this behavior.

Edited by itman

Share this post


Link to post
Share on other sites
Posted (edited)

These are paid versions, not trial.  They show this clearly in the license section with the expiration date of the licenses shown.

The option only reset to on when I finally clicked Accept after repeated times clicking Postpone on the popup window.  I then manually turned it back off in the hopes that somehow the option did not "stick" properly on the settings import - which were imported multiple times AFTER the installation and first scans had finished.  Now keeping on eye on it to see if it happens again.

The big question to ask is:  Why does the marketing popup only have Accept or Postpone as options?  Why no Decline?  That's slimy to say the least of ESET development.

Thanks.

Edited by CasualUser

Share this post


Link to post
Share on other sites

Can't explain why this happened on your installations.

I have been on this forum for 5 years and this is the first posting I can recollect this happening. From whom/where did you purchase your Eset licenses?

Share this post


Link to post
Share on other sites

You can disable marketing messages completely here:

image.png

Share this post


Link to post
Share on other sites
2 hours ago, Marcos said:

You can disable marketing messages completely here:

image.png

It seems the OP has this already disabled but is still getting alerts

Share this post


Link to post
Share on other sites
5 hours ago, peteyt said:

It seems the OP has this already disabled but is still getting alerts

The OP didn't say that he or she disabled it on each of the machines. If the IPM setting really look like that in my screen shot, then it's a bug. However, we have tested this thoroughly and didn't observe such incorrect behavior. Clicking X closes only the current notification about IPM messages and prevents it from being displayed again.

Share this post


Link to post
Share on other sites
Posted (edited)

 

22 hours ago, peteyt said:

It seems the OP has this already disabled but is still getting alerts

This person gets what I said since my first message.  Yes that is what my screens look like.  Yes the popup kept coming up and that option was still set to off.  My settings screen looks exactly like the one above.  On the first machine I manually turned it off.  On the other two I imported the settings file from the first which also disabled it on those two....which I checked to make sure was disabled.

And once again...when that popup comes up, why is there not an option to DECLINE it?  Seriously?  Answer that.  Horrible popup window to keep nagging or to turn on the nags, but not to turn them off without going into settings and finding that option manually.

Edited by CasualUser

Share this post


Link to post
Share on other sites
49 minutes ago, CasualUser said:

 

This person gets what I said since my first message.  Yes that is what my screens look like.  Yes the popup kept coming up and that option was still set to off.  My settings screen looks exactly like the one above.  On the first machine I manually turned it off.  On the other two I imported the settings file from the first which also disabled it on those two....which I checked to make sure was disabled.

And once again...when that popup comes up, why is there not an option to DECLINE it?  Seriously?  Answer that.  Horrible popup window to keep nagging or to turn on the nags, but not to turn them off without going into settings and finding that option manually.

Can I just check something. Are all 3 computers giving these warnings or just the 2 that you imported the settings to with the original working?

Share this post


Link to post
Share on other sites

They all popped up with it shortly after install once.  I believe the repeated popups were only from the two that had the setup file imported.  Those definitely did it multiple times.  I have not seen a popup since I manually toggled it "On", saved settings, and manually toggled it back "Off".  Seemed to be a bug where the setting import changed the toggle appearance but not the actual option it controls.  The original computer is my wives....she hasn't complained about it and doesn't remember seeing it.  Have to report that with a grain of doubt though.

I do IT consulting for a living, used to dealing / seeing these types of options daily with end users.  This is part of the reason not having a "Decline" option on that popup to permanently turn if off really gets under my skin frankly.

Thanks for your reply.  I will monitor it and update if it happens again.

Share this post


Link to post
Share on other sites
On 8/27/2019 at 9:52 PM, Marcos said:

The OP didn't say that he or she disabled it on each of the machines. If the IPM setting really look like that in my screen shot, then it's a bug. However, we have tested this thoroughly and didn't observe such incorrect behavior. Clicking X closes only the current notification about IPM messages and prevents it from being displayed again.

Re-read my original post please.  I specifically said I exported setting from the first computer to the other two computers.  I then specifically verified that settings showed properly and looked at this marketing setting in particular. Coming from AVG with their history of aggressive marketing even to paid versions of their software made me sensitive to this.   It showed correctly the same way your picture above shows it on ALL three computers.

Share this post


Link to post
Share on other sites

It's not about exporting and importing settings. If you want to disable even notifications about available messages, you must do it in the advanced setup on each of the machines. You didn't say that you did that. The IPM setting cannot be exported / imported since it's a per-unit setting specific for unique devices.

To sum it up, marketing messages are not displayed unless you explicitly enable them in the advanced setup. However, unless you configure IPM messages in the advanced setup, you may receive notifications that some messages are available. By clicking X you close a particular notification about a message being available.

Ie. in order to not receive any IPM notifications, make sure that on each machine the setting is configured, ie. it looks like

image.png

and not like

image.png

Users who want to receive marketing messages (e.g. offers to renew with discount) should keep it enabled, ie. the setting should like

image.png

Share this post


Link to post
Share on other sites
On 8/29/2019 at 2:47 AM, Marcos said:

It's not about exporting and importing settings. If you want to disable even notifications about available messages, you must do it in the advanced setup on each of the machines. You didn't say that you did that. The IPM setting cannot be exported / imported since it's a per-unit setting specific for unique devices.

To sum it up, marketing messages are not displayed unless you explicitly enable them in the advanced setup. However, unless you configure IPM messages in the advanced setup, you may receive notifications that some messages are available. By clicking X you close a particular notification about a message being available.

Ie. in order to not receive any IPM notifications, make sure that on each machine the setting is configured, ie. it looks like

image.png

and not like

image.png

Users who want to receive marketing messages (e.g. offers to renew with discount) should keep it enabled, ie. the setting should like

image.png

Sorry for the late reply.  I will reiterate, that doing the setting import changed the visual appearance of this option in the preferences to the "Off" setting you show above with the X graphic.  It did not have the checkbox or the question mark showing.  So from what I was able to see they were disabled after the settings import.  If this is not the way it functions then your system shows an incorrect status for this option after a settings import is done which visually turns this option off.  

I know what I saw on my end, I triple checked it and had to manually toggle it on and then back off to make it work as intended.

Have a good day.

Share this post


Link to post
Share on other sites
3 hours ago, CasualUser said:

Sorry for the late reply.  I will reiterate, that doing the setting import changed the visual appearance of this option in the preferences to the "Off" setting you show above with the X graphic.  It did not have the checkbox or the question mark showing.  So from what I was able to see they were disabled after the settings import.  If this is not the way it functions then your system shows an incorrect status for this option after a settings import is done which visually turns this option off.  

I know what I saw on my end, I triple checked it and had to manually toggle it on and then back off to make it work as intended.

Have a good day.

Sounds like a bug @Marcos . Noticed you said the setting has to be changed manually on each computer but it appears that eset displayed it as off because the original that had the settings copied from was set to off so the versions using the copied settings displayed it as off while actually not being off.

Share this post


Link to post
Share on other sites

Please provide a screen shot of the message you received. Was it really a notification about a marketing message or a marketing message itself that popped up?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...