Jump to content

How to allow Roboform to sync to internet?


Recommended Posts

Roboform cannot access the internet for synching. How do I add rule to allow it to sync? My firewall is in intereactive mode, I didn't see anything pop up when it tries to sync. Maybe I denied it in the past because of unfamiliarity. What is the name of the module that allows roboform to sync?

Edited by rsuryase
Link to comment
Share on other sites

  • ESET Insiders

Hello,
 
Are you using "Advanced setup > Web and email > Protocol filtering > SSL > Always scan SSL protocol"? If so, you will need to exclude the RoboForm certificate by switching to "Ask about non-visited sites (exclusions can be set)" with option "Apply created exceptions based on certificates" checked and exclude the RoboForm certificate. Once done you can change the setting back to "Always scan SSL protocol".
 
Edit: to correct typos...

Edited by puff-m-d
Link to comment
Share on other sites

Does temporarily disabling the firewall make a difference? If so, what mode is the firewall running in?

Yes. Turning off firewall solves the problem. Interactive mode.

Link to comment
Share on other sites

Hello,

 

Are you using "Advanced setup > Web and email > Protocol filtering > SSL > Always scan SSL protocol"? If so, you will need to exclude the RoboForm certificate by switching to "Ask about non-visited sites (exclusions can be set)" with option "Apply created exceptions based on certificates" checked and exclude the RoboForm certificate. Once done you can change the setting back to "Always scan SSL protocol".

 

Edit: to correct typos...

 My setup is Do not scan SSL protocol.

Link to comment
Share on other sites

  • Administrators

Yes. Turning off firewall solves the problem. Interactive mode.

Does it work in automatic mode to rule out that the possibility that the communication was blocked by a rule you've created? Please carry on as follows:

- clear the firewall log

- with firewall in automatic mode, enable logging of blocked connections in the IDS setup

- reproduce the problem

- post the firewall log records here

Link to comment
Share on other sites

Exactly, place in automatic mode, make the connection so the firewall blocks it. Then post your logs please.

Edited by Arakasi
Link to comment
Share on other sites

enable logging of blocked connections in the IDS setup ?

I did but too many information appears in the log. I changed to Learning mode, now Roboform is able to connect to internet. When i changed back to Interactive mode, Roboform still can connect to internet, so looks like my problem is fixed.

 

Looks like while in learning mode, it created 4 new rules for Roboform to allow it to connect to internet. Why isn't there a pop-up during interactive mode?

Edited by rsuryase
Link to comment
Share on other sites

  • Administrators

Looks like while in learning mode, it created 4 new rules for Roboform to allow it to connect to internet. Why isn't there a pop-up during interactive mode?

Please export your ESS configuration to an xml file and copy & paste the firewall rules related to Roboform here.
Link to comment
Share on other sites

Because the firewall created the rules to allow the connection always.

Interactive only gives pop ups on new connections and uses your rules to filter already seen ones.

Edited by Arakasi
Link to comment
Share on other sites

But before turning on learning mode, there is no rule to deny Roboform to connect to the internet.

Edited by rsuryase
Link to comment
Share on other sites

There is no way to tell that without uninstalling and then double checking your statement.

What you say is not the way interactive mode works.

All new connections get a popup, and what you choose, creates a rule. The rule is then applied when the same connection is seen again.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...