Jump to content

Can't deploy agents

Recommended Posts



For the pas few hours I've been trying to deploy the ERA agent to all clients in my network.


I am now using a single PC to test the deployment. Every time I get the following error, I've included commentary with each point:


Windows network remote deployment failed because remote ACCESS WAS DENIED to the target WINDOWS machine. Verify that:
1. 'account@domain.nl' has administrator rights or use local 'Administrator' account that is enabled on the target machine.  - I have tried both a domain admin account and a local admin account, both don't seem to work
2. '
account@domain.nl' password is not blank. - This is definitely not the case.
3. You can remotely log on to the workstation from the server. - I can both connect with Explorer and Remote Desktop
4. From server machine you can access 'net use \\PC.domainname\IPC$' from the Command Prompt. - Net Use gives a positive result
5. Change 'ESET Remote Administrator Server' service credentials from 'Network Service' to user with domain administrator permissions temporarily for deployment. - The service is running under the same administrator account used to perform the installation.

 I am at a loss what might be causing the issue.

Link to comment
Share on other sites

  • 3 months later...

Luminai......I have the same problem, i'm stuck with this error , I can't deploy de agent to the workstations(Active directory), do you solve the problem?

Link to comment
Share on other sites

@Luminai: Are you using a passphrase for the certificate? if yes does it include special characters?


I had problems installing the Agent vie the EraAgentInstaller.bat when the certificate had a passphrase with special characters set.

Is there any log on client side?

Link to comment
Share on other sites

  • Former ESET Employees

Has anyone tried the solution Marcos gave above?


Have you tried deploying the Agent Live installer via GPO which is the recommended way of deploying agent ?

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...