Jump to content

Firewall blocking my PC's internet connection sharing


Recommended Posts

 

Hi,

I have a big problem.
The ESET firewall does not allow me to use my computer's shared Internet on my phone.


I am using the following CMD commands to share my computer's PPPOE Internet connection:
netsh wlan set hostednetwork mod = allow ssid = MY SSID key = MY PASSWORD
netsh wlan start hostednetwork


After doing this, I could easily use the computer-shared internet on my phone.
After installing ESET internet security, the firewall cut off internet access for the phone, and the message "Internet may not be available" appeared in the WiFi section of the phone.
I tried different versions: 14.0.22, 13.2.18 or 12.2.30 but they all had this problem.
I put the firewall in interactive mode as well as learning mode, but the problem was not solved.
I put the shared internet ip (192.168.137.1-192.168.137.255) in the "trusted zone" section as well as the "Rule" and even the "excluded from IDS" section, but still the problem was not solved.
There is also a problem when I pause the firewall.


The problem is solved only when I completely disable the firewall or uninstall ESET.
Please help me to solve this problem.


"Excuse me. This is a Google translation."

Thanks

Link to comment
Share on other sites

  • Administrators

Does pausing the firewall make a difference? If so, run the firewall troubleshooting wizard to list recently blocked communications and unblock the desired one(s).

Link to comment
Share on other sites

No, the firewall pause does not make a difference. Only disabling it is effective.
There are also no recently blocked communications in the firewall troubleshooting section.

ESET.png

Screenshot_20210120-162242_Settings.jpg

Link to comment
Share on other sites

11 hours ago, Hamed811354 said:

I am using the following CMD commands to share my computer's PPPOE Internet connection:
netsh wlan set hostednetwork mod = allow ssid = MY SSID key = MY PASSWORD
netsh wlan start hostednetwork

Based on what is shown in this article: https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/hotspot-netsh-wlan-start-hostednetwork/9ebe358b-b28f-4a2d-b06a-c6333782aadd , you have to manually set this connection to shared status. Did you do this?

Also of note from this article:

Quote

but does your wireless network card support the hosted network? Type netsh wlan show driver in the Command Prompt or in PowerShell and then hit enter, then check if your network card supports this feature. But why don't you use the Hotspot Mobile feature integrated in Windows?

 

Link to comment
Share on other sites

Yes I did.

I did all the steps in that article carefully.
Like I said, when I completely disable the ESET firewall, my computer's shared internet connection works well on the phone. Like the pictures in this post.

But when I turn on the firewall, even if I put it in learning mode or interactive, it does not allow Internet sharing. Like the pictures in my previous post.

 

netsh.png

 

ESET-2.png

 

Screenshot_20210127-093003_Settings.thumb.jpg.f09640022bc02c5029136fd206b61027.jpg

Edited by Hamed811354
Link to comment
Share on other sites

In Eset Firewall settings -> Known networks, verify that two network connections exist; one for your LAN and one for the WAN connection.

I also suspect the issue here is Eset is not recognizing the WAN connection due to the way it is being established; i.e. via command line setup. Eset sets up its network connections based on DHCP initialization processing at user logon time, existing network connection reset, etc.. In other words, from existing router settings. You might have to manually add in Eset Network settings, a network connection for the WAN connection.

BTW - I assume you have not set up your smartphone to connect via your router?

Edited by itman
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...