Jump to content

issue between the Kaseya ESET plugin and the ERA environment


info@ictteamwork.nl
 Share

Go to solution Solved by BrandonArtz,

Recommended Posts

Hello everyone,

 

In our company we use the Kaseya ESET plugin to enroll ESET to our clients.

After we upgraded to ERA 6.3 we have a issue with deploying installation packages to our clients

 

How it basicly works:

You can make a task in the ESET plugin that will install the ERA agent, ESET endpoint antivirus and will activate it.

It worked fine in ERA 6.2.

After the update to 6.2 we run into a problem the package installs the ERA agent and  ESET enpoint antivirus without a issue and it says that the task was executed without a issue but when i log in to the client i see that ESET is'nt activated.

 

When i logged into ERA i saw that our whole activation task tab was full with activation tasks and then nver run (see the attached picture)

 

I deleted the tasks and manually activated the clients thinking it was a issue with the sync.

 

But when i logged in the next day i saw tons of activation tasks again in ERA.

I deleted then again and monitored it.

Every minute it will generate 20 tasks. I have no idea how to fix this issue.

post-11026-0-38083100-1456221060_thumb.png

Link to comment
Share on other sites

  • ESET Staff
  • Solution

Hello,

 

I am sorry that you are running into this issue. Due to changes in the version 6.3 API, the Kaseya plug-in only supports ERA v6.2. We are in the process now of fixing these issues and an updated version of the plug-in that supports ERA 6.3 will be available near the end of March/beginning of April. 

 

In the meantime, to fix the activation task issue you can perform a query on your Kaseya database that will prevent these empty tasks from getting created. "UPDATE eset.ClientMetaData SET pending_operation = 0"

 

I hope that helps!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...