Jump to content

Eset Firewall no longer allows connections through VNC


Go to solution Solved by kelepe,

Recommended Posts

Hi all,

I work as System Administrator in a small enterprise where we use ESET Endpoint Security for Windows centralized with an ESET Protect Cloud UI where we configure rules and criteria.

Since yesterday we're encountering an issue on the Eset Firewall. We use TightVNC Server installed on all Windows clients and listening on port 5900 in order to connect and support our colleagues, but the rule is no longer working correctly. I verified on some clients and, temporarily disabling ESET Firewall, I'm able to connect through VNC, as soon as I enable again it, the connection stops working.

We did NOT change any rule on the Protect Cloud side, so we cannot figure out why the rule is no longer working because it seems set up correctly:

image.png

I verified the Trusted Zone (Area attendibile) was set correctly and it includes every IP subnet we actually use at work.

Could you help me facing up this very annoying issue? It is preventing us to connect to other clients that need support. I'm fully open to every suggestion.

Thanks in advance

Link to comment
Share on other sites

  • Solution

Hello, shown policy is applied on clients tried to receive VNC connection on port 5900? If so, it is not correctly configured, because you should open port 5900 on local port as your direction is IN, and remote port use any, or ephemeral ports. On your server open OUT communication on port 5900 as remote port. Make sure your profile "Qualsiasi" is correctly applied. If you want to debug, make rule that enable communication on port 5900 - direction IN, enable logging (level warning), put it in front of your rules and see your communication what you should enable. YOu can post screen of that log, that we can help you out...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...