Jump to content

Problem with ESET when you do not receive a notification from the permission


Recommended Posts

My problem is that at some point, not always, but the permissions from ESET do not appear, also some applications start slowly, and when you exit them, they start not to respond.

Has anyone encountered the same problem, if so, how can I solve it?

Link to comment
Share on other sites

  • Administrators
2 hours ago, Deahty said:

the permissions from ESET do not appear

Please elaborate more on this. If you are referring to the UAC prompt, it's Windows which is responsible for permission elevation and display of the UAC window.

2 hours ago, Deahty said:

also some applications start slowly, and when you exit them, they start not to respond.

Does pausing or disabling any of the protection modules make a difference? If not, does the issue go away after temporarily uninstalling ESET and returns when you install the latest version and use default settings?

Link to comment
Share on other sites

3 hours ago, Marcos said:

Please elaborate more on this. If you are referring to the UAC prompt, it's Windows which is responsible for permission elevation and display of the UAC window.

Permission, I meant a window in which I can choose whether to allow the application to connect to the Internet, or to deny

Link to comment
Share on other sites

Do you have the Eset firewall filtering mode set to Interactive mode?

For a trouble free firewall experience, it is best to leave the firewall filtering mode set to the default Automatic mode.

Also, you posted in the NOD32 section of the forum. NOD32 does not contain a firewall. Do you have Internet Security installed instead?

Edited by itman
Link to comment
Share on other sites

1 hour ago, itman said:

Do you have the Eset firewall filtering mode set to Interactive mode?

For a trouble free firewall experience, it is best to leave the firewall filtering mode set to the default Automatic mode.

I must say, it is interesting that when the computer is shutting down, for a split second, the sound of the permission window appears, maybe this information will be somehow useful

Link to comment
Share on other sites

1 hour ago, itman said:

Do you have the Eset firewall filtering mode set to Interactive mode?

For a trouble free firewall experience, it is best to leave the firewall filtering mode set to the default Automatic mode.

Yes. Interactive mode is enabled. My guess is that this issue, and a few other non-ESET issues, appeared after a Windows (11) update, but that's just my guess

Link to comment
Share on other sites

  • Administrators

When the computer is starting or shutting down, you won't be asked to allow or deny the communication because gui is not running. The communication would be blocked. Or you mean that the dialog window does not appear when the system is started and you can open gui via the icon?

Link to comment
Share on other sites

4 hours ago, Marcos said:

When the computer is starting or shutting down, you won't be asked to allow or deny the communication because gui is not running. The communication would be blocked. Or you mean that the dialog window does not appear when the system is started and you can open gui via the icon?

I meant only the sound, the notification of the window that appears, but it will not appear, for the reason as you described above. (because PC is shutting down) I just wanted to describe everything I know about the problem, and my observations

Link to comment
Share on other sites

  • Administrators

Do you mean that the system is already started, the ESET icon appears in the tray and you get not interactive window asking about the communication? If so, please provide a dump of eguiproxy.exe created via the Task manager then.

Link to comment
Share on other sites

16 minutes ago, Marcos said:

Do you mean that the system is already started, the ESET icon appears in the tray and you get not interactive window asking about the communication? If so, please provide a dump of eguiproxy.exe created via the Task manager then.

In general, the problem is that when I start any applications, a window does not appear in which I can choose whether to allow the connection (firewall), this problem is solved by restarting the computer.

 

 

 I have some problems with English, but I hope that we understand each other.

Link to comment
Share on other sites

  • Administrators

Please provide a dump of eguiproxy.exe from time when a prompt window is supposed to pop up.

image.png

Link to comment
Share on other sites

Posted (edited)
1 hour ago, Marcos said:

Please provide a dump of eguiproxy.exe from time when a prompt window is supposed to pop up.

Cant send, more than 100MB (i have 114MB)

 

 

Edited by Deahty
Link to comment
Share on other sites

  • Administrators
1 hour ago, Deahty said:

Cant send, more than 100MB (i have 114MB)

Is that already compressed? If so, you can upload the archive to a safe location (OneDrive, Dropbox, etc.) and drop me a personal message with a download link.

Link to comment
Share on other sites

@Marcos

He is experiencing the same firewall interactive prompt issue many here complained before. Same issue, except people don't know how to describe it properly. And he is correct, when this happens, sometimes when you reboot the system you see the prompt before logging off and the way he mentioned he can hear the sound but no popup is the same I described in another topic.

Almost every issue I read regarding the firewall prompt or alert not showing is the same issue, but just described differently by different users. It's very unlikely that so many different ESET users on different computers have the same issue, unless this is a bug with the software. I have read over 100 topics now here in the forums, some old, some new of people describing the same issue, basically no prompt to allow or deny a program when using the firewall interactive mode.

I think I described in fairly detail how to reproduce this.

Link to comment
Share on other sites

  • Administrators

@Deahty has supplied a dump of eguiproxy which I've passed on to developers. Will keep you posted.

Does everybody with this issue have Windows 11 or it happens with Windows 10 or older Windows too? Do you have only one account created in the system?

P_ESSW-15997

Link to comment
Share on other sites

On 1/10/2023 at 6:31 PM, Marcos said:

Does everybody with this issue have Windows 11 or it happens with Windows 10 or older Windows too?

Using Win7 and EIS V16.0.24 I haven't encountered this new "version" of a "hiding"  (@Deahty, others) / out-of-the-monitor ( @VW00) firewall popup bug in interactive mode yet. But the info about the popup sound is interesting, I will check this out. (To hear sound I have to put on my headphone.) 

@VW00have you checked the Microsoft SysInternals Tools already? Contains PsKill with which you might kill the hanging process (not EIS / ESS of course) eventually. And Process Explorer (and another one). With the former one can fiddle different properties of a process for example the visibility of a window or popup / dialog box etc. I have used Process Explorer once and was able to make a not appearing popup in another program, ie. not ESS, visible and could close it correctly. As a developer, like me, you know what I'm talking about. (Others shouldn't use such tools except they know what they are doing.)

Link to comment
Share on other sites

  • 3 weeks later...

Following.

I've had the same problem for a while now as well (maybe 3-4 months with automatic updates turned on for ESET & Window 10 Pro 4 Workstations) where the interactive firewall notifications stops showing up.  The fix is to log off the session or reboot - I can't seem to find a quicker fix for it.  I'm glad I am not the only one that intentionally uses interactive firewall as this recent issue is a bit of a headache.

Link to comment
Share on other sites

On 1/31/2023 at 1:36 PM, p-rock said:

I've had the same problem for a while now as well (maybe 3-4 months with automatic updates turned on for ESET & Window 10 Pro 4 Workstations) where the interactive firewall notifications stops showing up.  The fix is to log off the session or reboot - I can't seem to find a quicker fix for it.  I'm glad I am not the only one that intentionally uses interactive firewall as this recent issue is a bit of a headache.

I noticed a very important thing, before the message with the permission to disappear forever (bug) I hear a notification sound, there may be some kind of failure in the application, but this is just my guess

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...