Jump to content

"Your Connection is not Private" security message on every website


c1234
 Share

Recommended Posts

After installing NOD32 on my new windows 10 laptop every website (including dropbox, facebook, twitter, slack, etc) I went to was blocked with a "Your Connection is not Private" error message and mentioned an invalid website certificate. This happened in Chrome, Firefox and Edge. I turned off the website monitoring features of NOD32 but this did not solve the issue. Only uninstalling NOD32 fixed the issue. I've used NOD32 for over 10 years and would like to keep using it. Any suggestions?

Edited by c1234
Link to comment
Share on other sites

  • Administrators

Sounds like the ESET root certificate was not imported properly to the trusted root CA certificate store during installation if a computer restart didn't help.

Try the following:
- reboot the machine
- without launching any browser disable SSL filtering in the advanced setup and click OK
- re-enable SSL filtering and click OK to close the setup
- launch a browser and try to open https websites to see if it works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...