Jump to content

ESS broken as of Windows 10 Build 14942


Recommended Posts

Preface:  I realize this is a Windows 10 Fast-Ring pre-release build.  IMO, the issue should be identified and resolved nonetheless.

 

After having ESS working reliably on Windows 10 for a good long while, I began experiencing issues getting Windows Updates. The issue exhibits when beginning some download (for example, a Windows Update download), and it will go to some seemingly random % completion and then just hang.  In other cases, it appears to complete the download, but the file will be corrupted.

 

I cleared caches, and followed Microsoft's suggested troubleshooting steps  but nothing would clear the issue with Windows Update.  It didn't even occur to me that ESS could be the issue until I was updating another product and the while the download appeared to work, the installation kept failing due to corruption of the downloaded file.

 

While troubleshooting, I turned of all protection and tested, but the issue remained.  Finally, in desperation, I completely uninstalled ESS and everything started to magically work again. I'm guessing its HIPS related but I'm not totally sure.

 

I tried it also with WIn 10 Build 14951 and today with Build14955.  The same issue occurs in each of these Fast Ring versions.

 

I also attempted to use Interactive and Smart detection modes, but even though I received the pop-up and told it to create a permanent rule, the issue still occurs.  Only a full uninstall will work-around the issue.

 

Would love to be able to reinstall and upgrade to V10 if anyone has a way to resolve this.

Link to comment
Share on other sites

Interesting.

 

Someone else in a recent forum posting complained of the same thing. His contention was that SSL protocol scanning was the issue. When he disabled it, he had no problems with Win Updates hanging. I thought that was originally "a bunch of baloney." Maybe not. Try disable SSL protocol scanning and then do a manual Win Update. Report back the results.

 

I also have had slow/hung Win 10 update downloads that I just attributed to MS servers or my ISP "throttling" my connection. How it get around the issue is just exit from Win Updating and then return to it a short time later. The Win Update download resumes and completes in short order w/o issue.

Edited by itman
Link to comment
Share on other sites

I appreciate the feedback but I'm not sure where SSL protocol scanning is in ESS. I've invested a whole bunch of (wasted) time at this point and will not be re-installing ESS until the next Win 10 build is released.  

 

I've also had slow/hung WIn 10 updates due to MS Server issues - I know what that looks like and this isn't it.  The updates immediately worked once I completely uninstalled ESS (like within a 10 minute period and after 3 days of trying with ESS still installed).

Link to comment
Share on other sites

Others have had various problems with SSL protocol. I haven't been able to find the switch in version 10, yet. Check help.

 

It is within Web & Email

Edited by ken1943
Link to comment
Share on other sites

  • Most Valued Members

I appreciate the feedback but I'm not sure where SSL protocol scanning is in ESS. I've invested a whole bunch of (wasted) time at this point and will not be re-installing ESS until the next Win 10 build is released.  

 

I've also had slow/hung WIn 10 updates due to MS Server issues - I know what that looks like and this isn't it.  The updates immediately worked once I completely uninstalled ESS (like within a 10 minute period and after 3 days of trying with ESS still installed).

 

It's in advanced setup - web and email - SSL/TLS

Link to comment
Share on other sites

  • ESET Insiders

It's in advanced setup - web and email - SSL/TLS

 

And strange thing happened, when I tried to disable scanning of SSL/TLS it gives me error that I'm not allowed to do so, so to upgrade my Windows Insider build (14942) the only option for me was uninstall ESSP (10.0.174.0) to do Windows Update.

Edited by mandiato
Link to comment
Share on other sites

  • Most Valued Members

It's in advanced setup - web and email - SSL/TLS

And strange thing happened, when I tried to disable scanning of SSL/TLS it gives me error that I'm not allowed to do so, so to upgrade my Windows Insider build (14942) the only option for me was uninstall ESSP (10.0.174.0) to do Windows Update.

Weird it seemed to disable for me. Maybe report it to eset. I'm on the stable public version of Windows 10 buthe can't see why it would make any difference

Link to comment
Share on other sites

My computer is also running the newest insider build and I have experienced this problem. It was kind of difficult to identify the issue, at first I thought it was my internal memory that was damaged because when i got this problem I run the Memory Diagnostics Tool in Windows and it reported that there was some hardware problem with the computer. To verify this I booted memtest86 from a USB-stick and the result of this showed no error at all with the memory. After some extensive troubleshooting from my part I uninstalled ESET Smart Security and did run the Memory Diagnostics Tool again and now the test was successful with no errors.

Link to comment
Share on other sites

MS just posted Build 14959, I'll give that a try shortly...its downloading now.

 

Post Install:

 

I'm noticing some issues but they may be related to MS rather than ESS.

 

ESS does seem to need a lot rule setups;  I tried to disable SSL and HIPS, rebooted but still had problems.  Removed ESS and system is running better again.

 

I think it probably just needs something setup that I'm missing - and that's half the problem.

I'm knowledgeable but not an ESS expert.  I'll try again over the next few days.

Edited by theojt
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...