Jump to content

Stardock's Windowblinds


Go to solution Solved by vpnuser,

Recommended Posts

I have 2 Computers running Windows 8 with current version of Smart Security 6. Had to turn off HIPS in both computers so Windowblinds can work. Is Eset trying to resolve this problem with Stardock?

Link to comment
Share on other sites

  • ESET Moderators

Hello Mecpooler,

 

with HIPS enabled the windowsblinds wasn't working at all?

If you experience issues with HIPS please enable logging of all blocked operations in HIPS setup and contact customer care with the HIPS log and SysInspector log for further analysis.

Link to comment
Share on other sites

NO, With HIPS enabled Stardock's Windowblinds won't load properly on either of my computers. Turn HIPS off & it works perfectly, but this is not a solution to the problem

Link to comment
Share on other sites

  • 2 weeks later...

I sent Eset support both logs & their reply was an e-mail explaining HIPS. No solution to this problem was given, nor when they may address the problem. So my solution to it was to turn HIPS on in Super anti-spyware pro which I also run in both computers.

Link to comment
Share on other sites

I hate to admit this, but I have never taken a computer class. So I can't figure out how to post the logs as they are too long. Also a couple of days ago I figured out that if you un-check self-defense in HIPS tru the advanced settings, Windblinds will load correctly with HIPS enabled. Thanks for trying to help.

Link to comment
Share on other sites

  • ESET Moderators

Hello Mecpooler,

 

in case it is blocked by Self-defense, it is probably touching protected winlogon.exe process.

 

To solve issue  create an exception rule:
 
Open ESET Advanced setup->Computer->Hips->Configure rules->New
1. Give a name of rule like: “exception for windows blinds”
2. Source applications tab: “Add..” -> select file: “C:\Program Files (x86)\Stardock\WindowBlinds\WBCore.exe” (depending on where WindowsBlinds is installed)
3. Target applications tab: Allow operations all operations* -> choose target process as “C:\Windows\System32\winlogon.exe”
4. Save a rule, reboot system
5. Check if works
Link to comment
Share on other sites

  • Solution
problem solved

 

1. Give a name of rule like: “exception for windows blinds”

2. Source applications tab: “Add..” -> select file: “C:\Program Files (x86)\Stardock\WindowBlinds\WBCore.exe” (depending on where WindowsBlinds is installed)

3. Target applications tab: Allow operations all operations* -> choose target process as “C:\Windows\System32\winlogon.exe”

4. Save a rule, apply Style

 

No reboot required. 

eset got transparent borders now too
Link to comment
Share on other sites

  • 1 year later...

I just installed ESET having replaced Bitdefender and the issue with Windowblinds took me hours to fix. I ultimately had to disable HIPS entirely. It was not only causing problems with Windowblinds but other programs like Clover as well (which is a program that integrates with explorer.exe [like windowsblinds] to allow you to open separate folders within the same window via different tabs like an internet-browser rather than having to open separate windows, thus being both more convenient and saving memory resources).

 

Now, in WIndows 8.1 on a new laptop (3 months old), whenever I go to apply a new Windowblinds 'skin' or visual style I receive an error "System error - Code 1400. Invalid Window handle". For most it still allows the skin to load and apply except for the style I was using when I first installed ESET.  I assume some corrupted data now prevents that style from installing correctly. As that visual style cost $6 and I've only been using it a couple weeks, I'm a little disappointed.  I'm working with Stardock to provide them my receipt and transaction confirmation to see if they can allow me to re-download and re-install it. Given that these compatibility issues have been known for over a year and a half now I'm not sure why they have not been addressed and fixed.

 

I will only say this is not a good start with ESET.

Link to comment
Share on other sites

Hello @ToddBowers,

sorry for your inconveniences. However next time it would be good if you could start a new topic as this topic is older than one year.

 

With "cover" you surely mean this...

hxxp://ejie.me/

 

BTW I have tested cover with ESS v 8.0.304.x and it worked fine as far as I see. What was/is your problem with cover?

post-3952-0-97563300-1419251547_thumb.pngpost-3952-0-31420200-1419251545_thumb.png

 

And for Windowblinds: Maybe the issue can be fixed when switching HIPS to learning mode, change the style in Windowblinds and then switch HIPS to your preferred mode back.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...