Jump to content

Archived

This topic is now archived and is closed to further replies.

citapinc

Can't Install ERA when SQL Express Already Installed

Recommended Posts

I just installed a new Windows Server 2012 R2 for a client and it's now the main Domain Controller for the network (11 computers). We have an application installed on the server that installed MSSQL Express already.

 

When I go to install ESET RA and select MS SQL Express, it says it's already installed which is correct.  However with MS-SQL Express you need to install it for each instance.  Therefore ESET needs to install MS SQL Express again for it's own database.

 

How can I get ESET RA to install and create a new SQL Express Database?

Share this post


Link to post
Share on other sites

Install ERA database to your MSSQL Express, or install manually new instance of MSSQL Express and use this instance as db server for ERA.

Share this post


Link to post
Share on other sites

Here's a tip for those having similar issues.

 

SQLManagementStudio_x64_ENU.exe and SQLEXPR_x64_ENU.exe many look identically the same but do two totally different things.  I was running the ManagementStudio exe and not the SQLExpr exe.

 

HOWEVER!!!!

 

Why is this so difficult now!  I've been working on this for three days now and I'm still not past the Database Server Connection screen.  I would strongly suggest dumping v6 installation code and going back to how v5 worked and installed.  That was simple and easy to work with.

 

I've created a new SQL Express Instance called ERA (your installation program should have done that for me!).  I'm now at the Database server connection screen and it's asking me for the database, ODBC Driver and such.  No matter what I do I can't get past this screen.

 

This is what I've entered in so far:

 

Database: MS SQL Server

ODBC Driver: SQL Server

Database name: era

Hostname: SERVER2013

Port: 1433

Username: sa

Password: XXXXXXXX

 

Database: MS SQL Server

ODBC Driver: SQL Server

Database name: era_db

Hostname: SERVER2013\ERA

Port: 1433

Username: sa

Password: XXXXXXXX

 

 

I've also gone into SQL Server Configuration Tool->SQL Server Network Configuration->Protocols for ERA and make sure TCP/IP is enabled and TCP Port is set to 1433.

 

What in the heck am I missing here????

Share this post


Link to post
Share on other sites

if this is a second installation of SQL Express as you indicate then you probbaly need to also specify the SQL instance name when you connect.

Share this post


Link to post
Share on other sites

I think there are running 2 instances on port 1433, and they cannot both run on same port.

Try to set ERA sql instance port to something else than 1433. Use SQL Server Configuration Manager for this, it should be installed with sql server.

 

In next version of ERA, Setup.exe will install "ERA" instance for you, running on port 14222. Until then, you must install sql server manually.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...