Jump to content

ESET PROTECT | BUG - Preview pane not showing the latest information


Recommended Posts

Hi
I noticed during our audit that the preview pane is showing the wrong information about the computer selected:

Here is a picture on the preview pane

image.png.4c5486ead9bfcd6d3a6a926503db9f39.png

Here is a picture when you open the computer object for more info:

image.png.dff7c3728919e6306a1e67162aec224d.png

 

the latest scan that appears on the preview pane is 21st of March (might be later, I didn't bother checking) 
I'm assuming it might be related to the hotfix that came out at the end of March? 
Could that be it? 

 

Also, might be unrelated.  This happened to me when trying to edit the widget. 
Any ideas what's up with that? (no colors)
image.png.21ce6514018ad384eef50ecefe245367.png

 

Thanks

Aviel

Link to comment
Share on other sites

  • ESET Staff

Thanks for reporting. It will be forwarded for further analysis, but it definitely seems to be wrong. I would expect it reports last recorded scan instead of latest as similar issue was present long time ago also in client details view.

Link to comment
Share on other sites

  • ESET Staff
On 5/9/2022 at 1:44 PM, avielc said:

Also, might be unrelated.  This happened to me when trying to edit the widget. 

Any ideas what's up with that? (no colors)
image.png.21ce6514018ad384eef50ecefe245367.png

 

Thanks

Aviel

Could you be please more specific of what you mean by edit of widget? Color schema is defined in configuration of respective report template, so it is possible that once edited, it is somehow overridden with incorrect property. If possible, some reproduction steps would be helpful so that it can be reported and possibly resolved for upcoming release.

Link to comment
Share on other sites

2 minutes ago, MartinK said:

Could you be please more specific of what you mean by edit of widget? Color schema is defined in configuration of respective report template, so it is possible that once edited, it is somehow overridden with incorrect property. If possible, some reproduction steps would be helpful so that it can be reported and possibly resolved for upcoming release.

I did try to edit that widget

for some reason it was reporting multiple entries of the same computer (which defeats the purpose of understanding which computers aren’t running scans. 
 

I did notice (comparing to other default widgets) there is a format editing option. However I couldn’t find the format to color it correctly. 
is there some documentation to explain this?

 

thanks! 

Link to comment
Share on other sites

  • ESET Staff
14 hours ago, avielc said:

I did try to edit that widget

for some reason it was reporting multiple entries of the same computer (which defeats the purpose of understanding which computers aren’t running scans. 
 

I did notice (comparing to other default widgets) there is a format editing option. However I couldn’t find the format to color it correctly. 
is there some documentation to explain this?

 

thanks! 

Behavior of coloring is defined in this section for this report template:
image.png


but it depends of what kind of data is to be rendered, as some coloring schemas might be used only with specific data values (for example severity-based coloring).
Regarding listing of the same device multiple times, it is most probably result of report definition, which probably lists device with each scan times reported. We do collect entry for each scan reported by product, so showing only latest one might require more complex report definition or proper ordering.

Also note, that the original issue with wrong last scan time was reported some time ago and is prepared for next service release. As I proposed, it was indeed problem with ordering, where not last, but oldest scan time was shown...

Link to comment
Share on other sites

Gotcha

I'll look into the format part (for some reason it didn't work for me the last time i tried) 

Do you have any guide on the correct report definition? (This all started because I tried to fix that and on the way lost the coloring. )

Regarding the original message about the oldest scan etc... glad to hear - looking forward to that fix.

Link to comment
Share on other sites

quick update (just noticed your screenshot now)

Thanks for the screenshot, I actually missed it completely and had to figure it out.

I  was trying to add coloring to the last scan interval. 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...