Jump to content

Banking protection not working


Recommended Posts

Win 10 Pro, Firefox 63.01 (64 bit) and EIS 12.0.27.0.

EIS has recently failed to start banking protection secure browser when I open my internet banking login page. There have been recent updates to Win 10, Firefox and EIS, so the cause is not clear. The only way I can open the secure browser is from within EIS, but that is not very convenient. Previously, I would open internet banking from a bookmark in Firefox and the secure browser would automatically open. How can I get this functionality back?

Link to comment
Share on other sites

  • Administrators

Does the error persist after a system restart? To make sure that the system has been fully restarted, run "shutdown -r -t 0" from the tart menu.

Link to comment
Share on other sites

Yes it does persist after system restart. Strangely, when I opened the login page to my stockbroker's secure site, the banking protection secure browser opened and offered itself for that site. I want it to do the same for my internet banking site!

Link to comment
Share on other sites

  • ESET Insiders

Any chance that your bank is either St George or Westpac? I know that BPP doesn't currently work with either of them and Firefox, though it should work with IE11.

Link to comment
Share on other sites

Aha!! My bank is Bank SA, which is owned by Westpac, so you have probably identified the problem. The problem has only recently appeared. BPP worked fine before I went overseas mid-October. I just tried MS Edge browser (is that IE11?) but there was no sign of BPP.

Link to comment
Share on other sites

  • ESET Insiders

I just tested https://ibanking.banksa.com.au/ibank/loginPage.action and can confirm that it doesn't work with Firefox but does work with IE 11 (Internet Explorer 11)

BTW. Bank SA seems to be using the same software as St George

Link to comment
Share on other sites

  • Administrators

ibanking.banksa.com.au uses HTTP/2. Since Banking and payment protection doesn't support HTTP/2 yet, it won't open in a secure browser automatically.

Link to comment
Share on other sites

  • ESET Insiders
1 hour ago, AndrewJones said:

I have the same problem but my bank is LLoyds

www.lloydsbank.com should work fine as it doesn't support HTTP/2.0

Which browser are you using?

Edited by stackz
Link to comment
Share on other sites

Thanks for all responses. It seems that the problem might affect a lot of users and that ESET should look at doing something about it.

Link to comment
Share on other sites

  • Administrators
On 11/7/2018 at 7:24 AM, DGT said:

Aha!! My bank is Bank SA, which is owned by Westpac, so you have probably identified the problem.

The website https://ibanking.banksa.com.au uses HTTP/2, hence it's not open in a secure browser automatically.

Link to comment
Share on other sites

I have recently noticed the same problem.  Using Google Favorites-  two bank websites that were saved with eset protection have lost the eset protection.  Bank of America and Associated Credit Union.  As I have been trying to get info., I also noticed that when using Google Chrome, it says "Not Secure" on the ese tbanking and payment protection url

Link to comment
Share on other sites

  • Administrators
7 hours ago, Jesse S. said:

I have recently noticed the same problem.  Using Google Favorites-  two bank websites that were saved with eset protection have lost the eset protection.  Bank of America and Associated Credit Union.  As I have been trying to get info., I also noticed that when using Google Chrome, it says "Not Secure" on the ese tbanking and payment protection url

That's weird. On my machine both were opened in a secure browser. Please post a list of installed ESET modules.

Is the eicar test file detected when you download it from https://secure.eicar.org/eicar_com.zip?

Link to comment
Share on other sites

13 hours ago, Jesse S. said:

I also noticed that when using Google Chrome, it says "Not Secure" on the ese tbanking and payment protection url

This is due to Chrome's recent changes to override the "lock" symbol processing for HTTPS web sites since "big brother" Google feels nothing on the web can be trusted unless Google "has in hands into it."

Link to comment
Share on other sites

  • 1 month later...

Still can not get St George Bank , Australia to open in protected browser ! Went thru support /reinstalled etc etc but on my two  PCs it does not work automatically. Thanks for the postings above .I now realise i am not alone ...please let my know if ESET fix it.

Link to comment
Share on other sites

  • Administrators
4 minutes ago, sydney2218 said:

Still can not get St George Bank , Australia to open in protected browser ! Went thru support /reinstalled etc etc but on my two  PCs it does not work automatically. Thanks for the postings above .I now realise i am not alone ...please let my know if ESET fix it.

I opened https://ibanking.stgeorge.com.au/ibank/loginPage.action in Firefox and was asked if I want to open it in a secure browser.

Link to comment
Share on other sites

On 12/12/2018 at 4:38 PM, Marcos said:

I opened https://ibanking.stgeorge.com.au/ibank/loginPage.action in Firefox and was asked if I want to open it in a secure browser.

ME, TOO. Opened to Login page (set for 1-time only).

Plan B  ... my FF 64 New Tab Setting is FF Home (Default) and the Protected Screen shows Menu Bar and Bookmarks Toolbar with Pinned Top Sites in the body and Same in Bookmarks Toolbar area. I paste desired Protected Site in BP Address Bar and Save as Bookmark to Bookmark Toolbar And / Or as Pinned Top Site on FF Home New Tab (default) setting.

Clk on working Protected site shtcut  in normal browser = BPP, see Bookmarks Toolbar OR clk New Tab and see Imgur below to choose from. Not a bad alternative IF no fix found here.

My New Tab Pg layout .........

https://imgur.com/Rd231t9

Edited by COStark26
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...