Jump to content

ESET is blocking Firefox


Recommended Posts

ESET is blocking Firefox. When i turn off firewall then Firefox works properly.  

I tried reinstall firefox. I deleted my all rules. But still no effect.

Link to comment
Share on other sites

  • Administrators

Please carry on as follows:
- delete all ESET firewall rules
- make sure that the firewall is set to automatic mode
- in the main gui -> help and support -> details for customer care, enable advanced logging
- reproduce the issue
- disable advanced logging
- gather logs with ELC.

Finally post the archive generated by ELC here.

Link to comment
Share on other sites

When I change mode from "interactive" to "automatic", firefox starts works properly. 

But when I turn back to "interactive" mode then I get "no internet" in firefox.

I have deleted all rules, then in chrome I get prompt (from eset) like "do you allow connection from chrome. ALLOW/BLOCK button", but firefox is still broken and I have no prompt.

Link to comment
Share on other sites

  • Administrators

The firewall log doesn't contain any records about blocked communication. It only shows that access to this forum was allowed.

Did you actually get a pop-up window with action selection in interactive mode? Did you reproduce the issue when advanced logging was enabled?

Link to comment
Share on other sites

yes I reproduced it.  Pop-up window with action selection doesent show for firefox application, for example for Chrome application it's was appear and it is working.

Link to comment
Share on other sites

55 minutes ago, Berez said:

When I change mode from "interactive" to "automatic", firefox starts works properly. 

You stated you deleted all your Firefox firewall rules. Are you sure about that? Did you carefully check to ensure that no custom rules are interspersed with Eset default firewall rules? 

Link to comment
Share on other sites

  • Administrators
4 minutes ago, itman said:

You stated you deleted all your Firefox firewall rules. Are you sure about that? Did you carefully check to ensure that no custom rules are interspersed with Eset default firewall rules? 

There were only a few permissive rules in the exported cfg. Also if a particular communication had been blocked, it would have been logged in the firewall log. However, the firewall log was empty.

To me it sounded like the window with action selection didn't pop up for some reason so Firefox's communication was effectively blocked. However, this is yet to be answered by the OP.

Link to comment
Share on other sites

Zezwól = "allow"

firefox  (the window does not want to show automatically in interactive mode, there is no rule)

image.png.0f024cd20974c7c5466ea9c439d230d9.pngfirefox:

 

for chrome (pop-up showed up, rule was created)

image.png.df33a640f3f72388c0f0a0ac445fc20a.png

 

image.png

Edited by Berez
Link to comment
Share on other sites

There is another issue, for putty.exe I dont see "eset pop-up window to allow connection". Putty return "permision denied" for SSH connection, when I disable eset firewall  then I can connect to server!

Link to comment
Share on other sites

For what is worth, I had issues with the Eset firewall in a previous version when I used it in Interactive mode and then started deleting rules in mass, re-adding new ones, etc.. It was as if somehow Eset was executing old rules that no longer appeared in the GUI interface. I also believe but really can't fully recollect that a firewall reset also did not fix the issue, and it was only fully rectified by a new Eset install. 

In any case, I always now use the firewall in Automatic mode only.

Link to comment
Share on other sites

I think It is possible that eset uses the old rules (invisibled in GUI), how can I delete the settings completely? I used the uninstall tool, and then again install eset, but still no effect

Link to comment
Share on other sites

2 hours ago, Berez said:

I used the uninstall tool, and then again install eset, but still no effect

In this case, there would not be any left-over firewall settings since you reinstalled.

I assume you are still using the firewall's Interactive mode. If so, try this. Manually create a firewall rule, if one doesn't exist, to allow outbound communication with full directory location specification for firefox.exe . Move the new or existing rule temporarily to the top of the existing rule set. Can you now connect using Firefox?

Edited by itman
Link to comment
Share on other sites

5 hours ago, Berez said:

I created and move firefox rule to top, but It still no-working ?

Very strange indeed. Delete that FireFox rule you created and moved to the top of the rule set.

You can try this.

Right before you are ready to open FireFox, switch the Eset firewall to "Learning" mode. Then open FireFox and hopefully you can connect w/o issue. Immediately shutdown FireFox. Open Eset GUI again and switch firewall mode to "Interactive." Try again to connect to FireFox. You should be able to do so w/o issue.

If FireFox still can't connect to FireFox in Learning mode, switch back Interactive mode and reply back in the forum this status.

If the FireFox connection is resolved, take a screen shot of the FireFox rule Eset created while in Learning mode.

Link to comment
Share on other sites

Hi,

@itman

when I switched to learning mode  (first time) then my firefox is still broken :( Should I take the next steps from your instructions?

Edited by Berez
Link to comment
Share on other sites

1. Try to open FireFox again.

2. Open the Eset GUI. Then open the Network Protection section.

2. Refer to the Troubleshooting Wizard section.

  • Does the count field shown in the below screen shot show a non-zero value? If so, open the Troubleshooting Wizard and see if FireFox shows as being blocked. If it is blocked, select "Unblock." Eset will create the necessary firewall rules to allow outbound communication for Firefox.

Eset_Network.thumb.png.280c963f083565490cc7fb52dd6d1c91.png

Edited by itman
Link to comment
Share on other sites

  • Most Valued Members

@Berez, Are you running any kind of a proxy in Firefox settings?

Did you try to uninstall Firefox and remove all settings and re-install it and see if ESET prompts you to allow/block it if you are running in interactive , or it Automatic it should automatically allow it.

Link to comment
Share on other sites

4 hours ago, Rami said:

Did you try to uninstall Firefox and remove all settings and re-install it and see if ESET prompts you to allow/block it if you are running in interactive , or it Automatic it should automatically allow it.

I also was going to recommend this as the next step.

It appears Firefox is the only browser where you are having issues when run in the firewall's Interactive mode. If there was any browser that would show problems, I would expect that to be Chrome which you stated alerts fine in Interactive mode. Also, prior to reinstalling Firefox, manually delete any existing firewall rules for it.

Further support for a Firefox reinstall is when you manually create a firewall rule for Firefox's outbound activity, Firefox still doesn't connect.

Another thing you can also do is check your Windows Audit Failure Event log for blocked Firefox connections. This should shed some light on what is actually blocking Firefox outbound connections.

Edited by itman
Link to comment
Share on other sites

  • Most Valued Members
Just now, itman said:

I also was going to recommend this as the next step.

It appears Firefox is the only browser where you are having issues when run in the firewall's Interactive mode. If there was any browser that would show problems, I would expect that to be Chrome which you stated alerts fine in Interactive mode.

Further support for a Firefox reinstall is when you manually create a firewall rule for Firefox's outbound activity, Firefox still doesn't connect.

Another thing you can also do is check your Windows Audit Failure Event log for blocked Firefox connections. This should shed some light on what is actually blocking Firefox outbound connections.

Weird thing is that I do use Firefox at Home , while being at Interactive and then to Automatic I didn't have any problems with it and with ESET v12

Link to comment
Share on other sites

3 minutes ago, Rami said:

Weird thing is that I do use Firefox at Home , while being at Interactive and then to Automatic I didn't have any problems with it and with ESET v12

As far as the OP's issue, I also suspect  Eset's Network, Application Experience, option might be a factor. Application Experience is only active when the firewall is in Interactive mode. Its purpose is to alert you when a program's hash value changes such as would happen as a result of a program update. It also checks existing firewall rules for the program and warns of insecure existing rules. I have seen this feature perform strangely, warning of existing rules that were OK and then deleting those rules. One option would be to temporarily disable Application Experience and see if that resolves the issue.

I didn't mention this option previously because the OP stated he had reinstalled Eset and the Firefox issue persisted. What I didn't ask was if @Berez imported his previous Eset settings after reinstallation? Do you do that @Berez

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...