Jump to content

Agent deployment task won't finish


cone
 Share

Recommended Posts

Hey,

We are having some problem with agent deployment. Task will state it's "starting" or "started", but it won't change it's status. I've checked and it's installing agent properly and it's reporting to server.
On ERA console dashboard I have two views: "Server tasks executions" and "Agent deployment tasks", the task will show as "started" or "starting" in first one, but in second one there's nothing about deployment, just some old data.

Last changes to ERA server was turning off SMBv1.0 and switching to SMBv2.0, so it's possible we did something wrong.


from ERA trace.log:
After starting deployment task, only this error shows up, but I don't know if it's related, because it's happening every hour.

2018-01-09 08:21:38 Error: CRepositoryModule [Thread 7f30817ea700]: Error retrieving packages: No such product 'com.eset.apps.business.eslc.linux'

 

Tell me what other logs you need and where to find them.

edit: task will switch it's status "starting task failed" after long time. Agent is installed anyway.


 

Edited by cone
Link to comment
Share on other sites

  • 3 weeks later...
  • ESET Staff

What platforms (Windows, Linux, Mac) are used in this scenario? If ERA is hosted on windows, I don't think disabling SMBv1 would be problem -> but there is known issue when deploying AGENTs from Linux ERA Server to windows client machines.

Execution process of remote deployment task is traced in SERVER's trace log, but it requires full verbosity level.

It is strange that even it takes so much time, there are no errors, and AGENT gets installed. It may be caused by fat that remote deployment tries multiple methods to connect to client machine (WMI, Windows network, SSH) and it is possible one of them results in a state that it takes long time to "timeout" and continue with working method. There is also requirement to download AGENT installer from client machine, which may also take some time ... what you meant by "long time"?

Has it actually worked before configuration changes or you have not tried remote deployment task previously? There is also tool called "Remote deployment tool" (see documentation for details) available for download, which may help in specific environments, especially when ERA is hosted on a machine that has not suitable permissions to access client machined for deployment, as tool is executed with permissions of administrator (may be domain administrator) instead of remote deployment task, which runs in context of ERA service account.

 

Link to comment
Share on other sites

  • ESET Staff

@cone  It´s important to mention, that this forum does not replace the standard customer care / support. It´s community forum, primarily intended You are entitled to contact your local ESET distributor, based on your location. if they will not be able to help you directly, they will track an official support ticket.

Edited by MichalJ
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...