Jump to content

Archived

This topic is now archived and is closed to further replies.

Samoréen

Old problem showing up again : "ESET requires your attention"

Recommended Posts

Hi,

Since installation of version 10.1.204.0 I keep seeing this message popping up from the system tray. Clicking on the notification has no effect (because actually there's nothing to pay attention to). This mainly happens when switching from an application to another using Alt-Tab (Windows 10 Pro 1511 64-bit).

This is really exasperating since I found no way to stop this misbehavior. This, added to other bugs and to the fact that I'm now unable to temporarily disable protection when I need to (a bug that should already be fixed) questions the way the people in the quality insurance dpt. at ESET are doing their job. I have used ESET NOD32 professionally for many years and I never had such problems. Now each version is bringing its share of regressions and corrections take too much time to be released.

Share this post


Link to post
Share on other sites

1, Try turning off the option to activate gamer mode if an application running in a full-screen mode is detected. Haven't come across other reports about this behavior manifesting when switching between applications.

2, V10.1 does not contain any major bugs, quite the contrary. It fixes several bugs from v10.0. The fact that the option to temporarily pause protection is missing in the tray icon menu is a minor bug that cannot compare to bugs preventing the user to work with the computer. Moreover, 99,99% of users should have no reason to turn off protection. I do that because I intentionally play with malware but can't imagine why home users (perhaps with the exception of advanced users) would need to do that. Please clarify.

ESET pays attention to quality and QA tests are performed before each release. As I have stated elsewhere, the problem with missing option to pause protection has been fixed and the fix will be included in 10.2 which is planned to be released later this year.

Share this post


Link to post
Share on other sites
37 minutes ago, Marcos said:

1, Try turning off the option to activate gamer mode if an application running in a full-screen mode is detected. Haven't come across other reports about this behavior manifesting when switching between applications.

Gamer mode is set to Paused and the option named "Do not display notifications when running applications in full-screen mode" is checked. Anyway, the problem occurs even when no application is running in full-screen mode.

Share this post


Link to post
Share on other sites
Just now, Samoréen said:

Gamer mode is set to Paused and the option named "Do not display notifications when running applications in full-screen mode" is checked. Anyway, the problem occurs even when no application is running in full-screen mode.

Does turning off "Do not display notifications when running applications in full-screen mode" make a difference?

Share this post


Link to post
Share on other sites
10 minutes ago, Marcos said:

Does turning off "Do not display notifications when running applications in full-screen mode" make a difference?

No. It's even worse. Moreover, if I open the ESET NOD32 UI, switch to another app using Alt-Tab and switch back to the ESET UI (still using alt-Tab), I can see that the Gamer Mode switch is sometimes briefly enabled (becomes orange) and then switches back to Paused after a few seconds.

Share this post


Link to post
Share on other sites

I should have mentioned that I'm using a dual display configuration. Maybe is this fooling the "full-screen" detection routine.

Share this post


Link to post
Share on other sites
10 minutes ago, Samoréen said:

I can see that the Gamer Mode switch is sometimes briefly enabled (becomes orange) and then switches back to Paused after a few seconds.

Attached is a screen capture demonstrating this. After one or two seconds, the Gamer Mode switch returns to Paused by itself.

nod32bug.jpg

Share this post


Link to post
Share on other sites

The problem disappears if I enable the Gamer Mode but this is not exactly what I want.

Share this post


Link to post
Share on other sites

If I uncheck the "Display notifications on Desktop" option with Gamer Mode disabled, this doesn't change anything : I'm still getting the same unwanted warnings when switching apps.

Share this post


Link to post
Share on other sites

Further testing...

No application running with exception of the ESET NOD32 UI, which is the only opened window on the desktop. I use the Alt-Tab combo a couple of times and voilà, the Gamer Mode switch is briefly enabled (becomes orange and then back to paused state) and after that I get the infamous "ESET requires your attention" message. I can reproduce at will.

 

Share this post


Link to post
Share on other sites

Marcos,

Could you give me some information about how ESET NOD32 determines that a window is full-screen. I could then look in my system if such a (hidden) window exists using a window spy tool. I'm a former developer, I can deal with this.

Share this post


Link to post
Share on other sites

Hello,

I'm not 100% sure but I think it checks the resolution of an active window VS the display resolutions, if it matches it triggers the gamer mode.

Regards, P.R.

Share this post


Link to post
Share on other sites
3 hours ago, Peter Randziak said:

I'm not 100% sure but I think it checks the resolution of an active window VS the display resolutions

Thanks. You mean, it checks the size in pixels of the active window compared to the display resolution, I guess ? I have no such window active when the problem occurs.

However, I do have some hidden windows that have dimensions corresponding to the screen display (or bigger : e.g. 1921x1201). They all belong to the system with exception of a couple of them belonging to Microsoft Office (Outlook).

Since I didn't have the problem before version 10.1.204.0, maybe the detection algorithm has changed and is now mistakenly taking the hidden windows into account ?

Share this post


Link to post
Share on other sites

Yes that is my understanding. I will have to check it.

Even the Desktop is an application so it might be detected in this multi-display environment.

P.R.

Share this post


Link to post
Share on other sites

Hello Samoréen,

I got and info from the Dev team that it should be resolved in version 10.2 by JustInTime gamer mode detection.

Until than we may recommend you to turn off the status message for the gamer mode as shown on the attached screenshot.

Regards, P.R.

Untitled.png

Share this post


Link to post
Share on other sites

I am having the same issue.  I am on one laptop computer.  It seems to happen when I use Alt-Tab to change programs or documents.  Should I try the gamer mode change too?

 

I am using NOD32 and I do not have the same screen that you show above.

Share this post


Link to post
Share on other sites
24 minutes ago, cbmolly said:

I am using NOD32 and I do not have the same screen that you show above.

Try uninstalling ESET and installing the latest version 10.1 from scratch. Then you should get the above screen with an option to disable change of protection status when Gamer mode is activated.

Share this post


Link to post
Share on other sites
21 minutes ago, Marcos said:

Try uninstalling ESET and installing the latest version 10.1 from scratch. Then you should get the above screen with an option to disable change of protection status when Gamer mode is activated.

I just installed it last week because I have a new computer.  It seems strange I would have to do it again, but I will try it.

Share this post


Link to post
Share on other sites
26 minutes ago, cbmolly said:

I just installed it last week because I have a new computer.  It seems strange I would have to do it again, but I will try it.

If you can't find it in the advanced setup, please post a screen shot of what you see in the User interface setup section.

Share this post


Link to post
Share on other sites
1 hour ago, Marcos said:

If you can't find it in the advanced setup, please post a screen shot of what you see in the User interface setup section.

I found it and turned off Gamer Mode.  Is this something I should turn back on once the new update happens?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...