Jump to content

Remote Deployment msiexec


dazza007
 Share

Recommended Posts

I have tested the package with the correct permissions (double checked with effective permissions) of agent_x64 msi with the config.msi using msiexec locally and the I get 1603.

I get the following errors in the logfile 

Property(S): P_DB_STATUS = DB_UPGRADEABLE
Property(S): P_DB_CONNECTION_STATUS = OK
Property(S): SOURCEDIR = deleted
Property(S): SourcedirProduct = {41F12F70-5FA9-43F5-94F4-53B54EB4EEC4}
MSI (s) (D0:F4) [15:33:25:593]: Product: ESET Remote Administrator Agent -- Configuration failed.

MSI (s) (D0:F4) [15:33:25:593]: Windows Installer reconfigured the product. Product Name: ESET Remote Administrator Agent. Product Version: 6.5.522.0. Product Language: 1033. Manufacturer: ESET, spol. s r.o.. Reconfiguration success or error status: 1603.

=== Logging stopped: 06/04/2017  15:33:25 ===

 

The situation is not improved by manually uninstalling the software and reinstalling the software

I tried the different switches /qn /qb no change.

 

When manually installing and logging the package a popup conveys a critical error, the logs of which shows the same error above

Manually installing the software, to update the previous release 6.4, starts a repair. The package has been used by group policy to update more than  300 clients, however I need to deploy the package too where group policy software deployment is not working. 

The password (that locks down the software) is not required is there a way of passing this to the msi?

Many thanks

Darren

Edited by dazza007
Link to comment
Share on other sites

I had the same issue, kinda.

I'm having to get to the machines manually and re-do them.

I've found that NOT having all the latest Windows updates on machines has caused massive problems and WSUS was also shafted on those (Windows 10 install without a Cumulative update past September 2016)

Link to comment
Share on other sites

  • 3 weeks later...

I just had an issue using another method of deployment and figured out that the comma in the company name caused issues. 

Is it possible to remove the comma in the company name (ESET, spol. s r.o.. ) as it would commonly cause errors in different deployment mechanisms?

Link to comment
Share on other sites

  • ESET Staff

Could you be more specific of deployment scenario that was not working because of specific vendor name? We had not seen any such report and compa in vendor name is used for a long time as it is par ot official company name.

Link to comment
Share on other sites

I was using WSUS Package Installer. The MSI provided the company details which creates a folder to which the packages are placed. 

The package is imported into WSUS, however a refresh or new login to the WSUS package installer, the package vanishes from the console. 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...