Jump to content

http proxy era ova


macros
 Share

Recommended Posts

hello,

ova is the best and fast way to have era server in network. good job to Eset team.

i want to ask something.

if we checklist option (Enables HTTP forward proxy for caching updates) in first time appliance configuration.

Capture.JPG

 

We need to to run this command or not?
hxxp://help.eset.com/era_deploy_va/64/en-US/index.html?enable_apache_http_proxy.htm

When i run that command, it says:

[root@era ~]# systemctl enable htcacheclean
The unit files have no [Install] section. They are not meant to be enabled
using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).

 

Thank you,

Link to comment
Share on other sites

  • ESET Staff

Hi Macros,

If you enable the apache http proxy during deployment of the appliance, you do not have to enable it manually afterwards.

It is listed here: http://help.eset.com/era_deploy_va/64/en-US/index.html?config_server_va.htm

It is enabled by default, and default policies are created and assigned to the group "all" that instruct all of our products, to communicate with ESET servers via this proxy server, which caches installers / updates for them.

Link to comment
Share on other sites

On a side note, it seems that in the 6.4 appliance the  htcacheclean service isn't properly enabled regardless of whether ENABLE HTTP PROXY is selected during initial setup. I had to run following 2 commands to properly enable it:

 

mkdir -p /etc/systemd/system/httpd.service.requires

ln -s /usr/lib/systemd/system/htcacheclean.service /etc/systemd/system/httpd.service.requires

Link to comment
Share on other sites

  • ESET Staff
On 11. 1. 2017 at 9:48 AM, V2TW said:

On a side note, it seems that in the 6.4 appliance the  htcacheclean service isn't properly enabled regardless of whether ENABLE HTTP PROXY is selected during initial setup. I had to run following 2 commands to properly enable it:

 

mkdir -p /etc/systemd/system/httpd.service.requires

ln -s /usr/lib/systemd/system/htcacheclean.service /etc/systemd/system/httpd.service.requires

Thanks for reporting. This problem will be fixed in appliance released with ERA 6.5. Unfortunately ERA 6.4 appliances (based on CentOS7) do require fix as you mentioned.

Link to comment
Share on other sites

  • 2 weeks later...
On 11/1/2017 at 3:48 PM, V2TW said:

On a side note, it seems that in the 6.4 appliance the  htcacheclean service isn't properly enabled regardless of whether ENABLE HTTP PROXY is selected during initial setup. I had to run following 2 commands to properly enable it:

 

mkdir -p /etc/systemd/system/httpd.service.requires

ln -s /usr/lib/systemd/system/htcacheclean.service /etc/systemd/system/httpd.service.requires

Thank you V2TW

Noted.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...