Jump to content

Software installation not occurring


Recommended Posts

Hi,

 

We are using ESET Remote Administration 6.x to manage our ESET network (which I will add is terrible compared to v 5).

 

Two TS/RDS servers have the Eset Remote Management agent installed, however whenever I try to do a remote push of Eset File Security for Windows Servers nothing happens. I've gone through the checklist of requirements for remote push, and all is setup as outlined in the guide.

 

I've followed this guide: hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN3605on doing the remote deployment. When I get to the last bit about the executions, my page is empty. The servers never show that anything was executed, ever.

 

I've tried removing the agent and re-deploying it via the ERAremoteagentinstaller batch file, which installs, I can just never get the AV product deployed.

 

Is there a way to manually install the product (with an MSI like every normal application) or a way to diagnose what is going on here?

 

Thanks.

 

Link to comment
Share on other sites

  • Administrators

A recommended way of installing ESET remotely is by using Agent Live installer (ie. not a push install which requires a lot of conditions to be fulfilled due to the way Windows works). You can deploy it globally via GPO for instance.

Once agent has been installed on clients, you can send a software install task to the clients so that agent downloads and installs Endpoint.

 

You wrote "I've tried removing the agent and re-deploying it via the ERAremoteagentinstaller batch file, which installs, I can just never get the AV product deployed." Does that mean that clients with agent installed now appear in ERA but sending a software install task is failing?

Link to comment
Share on other sites

A recommended way of installing ESET remotely is by using Agent Live installer (ie. not a push install which requires a lot of conditions to be fulfilled due to the way Windows works). You can deploy it globally via GPO for instance.

Once agent has been installed on clients, you can send a software install task to the clients so that agent downloads and installs Endpoint.

 

You wrote "I've tried removing the agent and re-deploying it via the ERAremoteagentinstaller batch file, which installs, I can just never get the AV product deployed." Does that mean that clients with agent installed now appear in ERA but sending a software install task is failing?

 

Thanks for the reply.

 

My two servers, have the remote agent installed and are showing up in ERA. The software install task is what is failing, correct. I don't even see any events under the software install task at all.

Link to comment
Share on other sites

  • Administrators

In such case, I assume that also a local install would fail. Would it be possible to try it? If it fails, we'd need install logs to find out what is causing the failure.

Link to comment
Share on other sites

Hi Marcos,

 

How do I actually do a local installation? What I would ideally like is an MSI of the eset package, but from what I understand this isn't possible?

 

Cheers.

Link to comment
Share on other sites

  • Administrators

How do I actually do a local installation? What I would ideally like is an MSI of the eset package, but from what I understand this isn't possible?

 

It's possible. You can download an Endpoint msi installer from ESET's website. Agent can be installed later after installing Endpoint.

Link to comment
Share on other sites

  • 9 months later...

I am in similar situation. I have a ESET Remote Administrator Appliance (Centos 6.7) up and running. On the client side the ESET Remote Administrator Agent is running -- flawlessly.

 

When i try to run a task with ESET Endpoint Antivirus 6 installation, it fails. Contrary to the Marcos post at 22 June 2015 - 02:01 PM, if i try a local installation with Offline installer, it works.

 

Moreover, if i try to activate this EEA6 by the means of ESET Remote Administrator, it fails too.

 

Client system is domain-joined Windows 7 Professional 32bit.

Link to comment
Share on other sites

  • ESET Staff

I am in similar situation. I have a ESET Remote Administrator Appliance (Centos 6.7) up and running. On the client side the ESET Remote Administrator Agent is running -- flawlessly.

 

When i try to run a task with ESET Endpoint Antivirus 6 installation, it fails. Contrary to the Marcos post at 22 June 2015 - 02:01 PM, if i try a local installation with Offline installer, it works.

 

Moreover, if i try to activate this EEA6 by the means of ESET Remote Administrator, it fails too.

 

Client system is domain-joined Windows 7 Professional 32bit.

 

We would appreciate if you could check or provide logs from target client. Especially software installation log containing full-verbosity MSIEXEC log of last software installation task execution:

C:\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Logs\software-installation.log

In case there won't be any log there is a chance installation not even started -> it may have failed during package download from ESET servers (has this client computer direct visibility to internet?). If this is the case, there would be record in main AGENTs trace log:

C:\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Logs\trace.log

listed either as "Error:", or most probably also under subdomain "SoftwareInstallation".

Link to comment
Share on other sites

  • 2 months later...

Hi all, same issue here, scheduled installation fails. All computers does have Agent installed, they are shown in list as managed but when i want to install the software on any of them, it fails with "Task failed, try to install software manually." There are no error logs, not even trace.log file, only som few hours old info.

I must admit this era6 software is awful, lots of trouble for less results. Today i am working on a package of 7 computers but in 11 days gonna need to do it again for 20 computers and then again for 50 computer. If we can't somehow solve this, i must say i am considering other antivirus software.

What on earth made you discontinue the earlier Era?

Link to comment
Share on other sites

  • 7 months later...

I also am completely unable to install ESET Antivirus via Remote Agent install tasks.  They simply never run.  Scheduled or ASAP.  No reason is given.  There is not logging or reporting.  I can't even know when ASAP is supposed to occur.  All tasks are listed as "Planned."  PLANNED FOR WHEN!!!!!

Link to comment
Share on other sites

  • Administrators
46 minutes ago, Pierce MacMillan said:

I also am completely unable to install ESET Antivirus via Remote Agent install tasks.  They simply never run.  Scheduled or ASAP.  No reason is given.  There is not logging or reporting.  I can't even know when ASAP is supposed to occur.  All tasks are listed as "Planned."  PLANNED FOR WHEN!!!!!

If you check client details in the ERA console, has the client connected recently? If you check C:\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Logs\status.html on the client, are there any errors in red or all records are green?

While troubleshooting issues, it would be good if you edit agent's policy and change the logging verbosity to "debug" or "trace". Do this also for the server in Admin -> Server settings -> Advanced settings -> Logging. After the policy has been applied on the agent, reproduce the issue and then provide us with trace.log logs both from the server and the client.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...