Jump to content

ESET AV 11.0.2044 fails to automatically restart when installed from PROTECT onprem console

Recommended Posts

From ESET Protect Console, we right click the computer->Update->Update ESET Products

ESET AV is updated from 11.0.2032 to 11.0.2044.  The 2044 splash screen appears then the restart dialog is presented.

The Restart dialog counts down to the 17 second mark and then closes without a reboot.

The computer and the eset installation is left in a computer must be rebooted state.

Same result whether there is someone logged into the computer or not.

Tried this on 5 Windows 10 22H2 24-02 computers with same result.

Agent release is 11.0.503

Device Restart Popup.png

ESET Protect.png



UpdateandRestartrequestedfrom Console.png

Link to comment
Share on other sites

  • Administrators

We'll look into it, however, the preferred way of updating ESET Endpoint is by enabling the auto-update policy (in case you have disabled it).

If you want to force upgrade shortly after the release without the need to wait a few more weeks to get the update installed automatically, please use the "Check for product update" task in ESET PROTECT:


This would download the update but it would install after the user restarts or turns on the system next time.

Link to comment
Share on other sites

Sorry, we have an enterprise environment where all software is centrally managed and auto-update has been disabled in ESET PROTECT.

This morning, I created a Software Installation Task to install the download .msi file from an SMB using the reboot option.

Same result.  Update completes.  Restart dialog counts down from 30 seconds and then closes at 17 seconds leaving ESET in must reboot status.

There is something wrong within the 11.0.2044 installer.

We will hold off on this release until this is fixed.

Link to comment
Share on other sites

I had the same experience. Upgrading to 11.0.2044 by selecting computers to upgrade, and selecting Restart when needed.

The install finishes but clients don't reboot, as if Restart when needed was not selected. I didn't check if there was a countdown screen though.

This is both Windows 10 and 11, latest CU.

Edit: I'm using Endpoint Security.

Edited by FRiC
Link to comment
Share on other sites

  • Administrators

It was confirmed to be a bug in Endpoint v11. Anyways, we suggest using the "Check for update" task instead of a software installation task which uninstalls the product completely before installing it from scratch and thus the chance of encountering installation issues is higher that upgrade via the so-called uPCU.

Link to comment
Share on other sites

I updated our windows server AV this weekend to 11.0.12008.

After the MSI install completes, there is no reboot prompt.  Sound familiar?

Looks like a problem with your installation software.  Are you still using Wix installer?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...