Jump to content

After installing SSP I can no longer use my Brother scanner.

Recommended Posts

I have a Brother ADS2700W sheetfed scanner, connected via USB to my computer.
It has worked fine for a number of years. 

After installing SSP.

I have found out how I can allow the device.
When the scanner is connected a window pops up from "Device guard(?)" saying that the scanner has connected, and it has been allowed.

Still when I press "Scan to Computer" which is how I have usually used it the device says it cannot connect to the PC.
When I try to use Brothers scan tool it finds the scanner, it can read the serial etc, but it cannot scan. 

When I try to use the built in "Windows scan" it actually runs the paper through the scanner but hten says something went
wrong and no picture appears.

 I have tried uninstalling the drivers and software, and reinstalling them without any difference.

Could this be a problem based on the scanner can be seen as a scanner and as usb storage?

Anything I can try? (not involving reinstalling Windows 11)

Eset Smart Security Premium on 
OS Version, Microsoft Windows 11 Pro (64-bit, x64), 10.0.22621.2428

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...