Jump to content

GTA V - online and EIS


Go to solution Solved by shicomm,

Recommended Posts

There was another topic about this but it was quite old and closed off , new try here.

 

I purchased gta-v thru the epic store and used it for a long time up to a couple of months before.

Since a new update came out i wanted to continue the game again.

Launched the epic store ; was able to install the update but then i got stuck.

After a long wait the game does launch but keeps on telling me that i'm offline.

 

I tried absolutely anything ; added firewall rules ( did not need to in the past.. ) , switched the firewall on/off , tried the gamer mode..  nothing fully works...

In some cases i can get a bit further in the processes but i'm totally unable to get the game to launch online.

Out of curiousity i tried de-installing EIS and voilla ; everything works like a charm...

 

I'm sure i've missed something but i'm totally unsure how and what.

Running windows 11 pro 22h2 fully up to date and the latest version of EIS.

Link to comment
Share on other sites

  • Most Valued Members

Is there a rule to allow Rockstar Game Launcher web access ??


I not just run GTA , then alt-tab out of the game and go into SETUP > NETWORK PROTECTION . TROUBLESHOOTING WIZARD  and allow the access from there.

Link to comment
Share on other sites

  • Administrators

The OP wrote that he had tried switching the firewall off to no avail.  However, then ESET should not have any effect on network communication with the exception of http/https protocols.

Does actually temporarily uninstalling ESET make a difference? If not, the root cause of the issue must be elsewhere.

Link to comment
Share on other sites

  • Most Valued Members
9 minutes ago, Marcos said:

The OP wrote that he had tried switching the firewall off to no avail.  However, then ESET should not have any effect on network communication with the exception of http/https protocols.

Does actually temporarily uninstalling ESET make a difference? If not, the root cause of the issue must be elsewhere.

He said that uninstalling fixed it,

I have a question on this matter Marcos if you please

If I have a rule block on example.exe , and then I shutdown the firewall , will that rule still apply and be blocked or it will pass normally since I shut down the firewall?

Link to comment
Share on other sites

  • Administrators
1 minute ago, Nightowl said:

If I have a rule block on example.exe , and then I shutdown the firewall , will that rule still apply and be blocked or it will pass normally since I shut down the firewall?

If you pause or disable the firewall no rules will be applied whatsoever.

Link to comment
Share on other sites

  • Most Valued Members
1 minute ago, Marcos said:

If you pause or disable the firewall no rules will be applied whatsoever.

I understand you,

Thanks for the explanation.

Link to comment
Share on other sites

Uninstalling EIS did fix the issue indeed so the issues must be with EIS...

What i just dont understand is that adding all executables and folders ( rock* social , rock* games launcher and the gtav folder ) to both firewall and HIPS doesnt fix this.

Something else must connect and get blocked but i cant find out what that is.

It could be the H2 update of win 11 that messed this up or one of the EIS updates , it used to work absolutely fine with no need to add rules or turn off protection.

 

Link to comment
Share on other sites

  • Most Valued Members

Try as cyberhash suggested , when the game says you are offline , alt tab to Setup Protection in ESET and then Network Troubleshooting , see if you can find Rockstar launcher or GTA exe there being blocked.

Link to comment
Share on other sites

Will try that network troubleshooting thing later today , would make no sense since even disabling the firewall did not work.

Both adding all the folders to hips and disabling it did not work.

Link to comment
Share on other sites

  • Administrators
1 minute ago, shicomm said:

 and disabling it did not work.

Just to make sure, did you reboot the machine afterwads?

What about disabling network protection in the advanced setup?

Link to comment
Share on other sites

Whenever you make changes to HIPS there is a prompt to reboot so i did so.

Again ; adding the folders to the exclusion of HIPS did not work either. 

 

Disabling network protection might work ; i'll also look into that later today.

Link to comment
Share on other sites

  • Solution

Update:

 

I have no idea how but after a couple of days the problem seems to have fixed itself.

After a couple of hickups with rock* social i got in while keeping eset running as usual.

The topic can be closed :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...