Jump to content

Upgrading ESMC 7.0.553.0


ShaneDT
 Share

Recommended Posts

Hi ESET support. Hope everyone is well.

I've started getting "ESET Management Agent is outdated" alerts on some computers this week even though the Agent on these computers is already v7.2 and most have been updated to the latest 7.2.1266. So I guess it's time to stop putting off upgrading the server.

Some questions. I'll create certificate and database backups first.
Are there any known issues with upgrading from 7.0.553.0 to 7.2.11.1?
Should I use the Help / Update Product method or Client Task / SMC Components Upgrade or manually download the latest ESMC and do a manual upgrade?
Which is the simplest and less likely option to cause issues?
Should I upgrade to 7.0.557.0 first (the latest 7.0 build)?

Do I need to update the agent on all the client computers first? 
Most are already 7.2 but some are 7.1 and possibly 7.0. These are customer computers so could take weeks to organise with the customers to get these all updated (don't ask...).

The server is Windows Server 2012 R2 with all the latest updates installed.

Thanks.

 

Link to comment
Share on other sites

  • Administrators

Do you use the latest ESMC server 7.2 and only the agent on clients is outdated? If so, then sending an ESMC component upgrade task to clients would be enough. To upgrade Endpoint to the latest version 7.3.2041, send a software installation task to clients (we recommend not to do it at once and use an http proxy by agents to cache the installer).

If you want to upgrade also the ESMC server, back up the database and export the server and peer agent certificates as well as the CA certificate and then send an ESMC component upgrade task to the server. The upgrade may take several minutes (10 or more) during which logging in the ESMC console will not work.

Link to comment
Share on other sites

Hi Marcos, no I'm asking about upgrading the server. Server is currently 7.0.553.

So you recommend go straight to the latest version using Client Task / SMC Components Upgrade? Just run it, let it finish and I guess restart the server? Nothing else to do?

Will I have any issues if any of the client computers are running an older version of the agent (all 7.0 or above, most are already 7.2)?

Do I also need to upgrade Apache or is this upgraded along with Components Upgrade?

If not is there documented process to upgrade Apache? 

Are there any other components that need to be separately upgraded on the server?

Thanks.

Link to comment
Share on other sites

10 hours ago, ShaneDT said:

I've started getting "ESET Management Agent is outdated" alerts on some computers this week even though the Agent on these computers is already v7.2 and most have been updated to the latest 7.2.1266. So I guess it's time to stop putting off upgrading the server.

I have the latest ESET SMC server version and I see the same issue suddenly happening over the weekend. On the main computers screen it says "ESET Management Agent is outdated" on some computers but if I drill down to one of those computers from the dashboard and view it's installed applications, the ESET agent version (7.2.1266.0) says it is "Up-to-date version". So it seems to be a bug since one part of ESET says the agent it is up to date and another says it is out of date. I am going to call support later today to have them sort it out.

 

Link to comment
Share on other sites

1 hour ago, GregA said:

I have the latest ESET SMC server version and I see the same issue suddenly happening over the weekend. On the main computers screen it says "ESET Management Agent is outdated" on some computers but if I drill down to one of those computers from the dashboard and view it's installed applications, the ESET agent version (7.2.1266.0) says it is "Up-to-date version". So it seems to be a bug since one part of ESET says the agent it is up to date and another says it is out of date. I am going to call support later today to have them sort it out.

 

GregA so you have the latest version ESMC server and the latest version of the agent installed on your client computers and you're still getting the warning message? 

Very strange. Marcos does ESET have any idea what is suddenly triggering this warning? Clearly it's not the server or agent version that is the problem. On my own server I have this warning appearing on maybe a third of my customer computers, regardless of what version agent is installed. And nothing changed on my server or customer computers that I'm aware of that could have triggered it. It appears to be affecting a random sample of client computers.

Anyway I do need to update the server so await your answers to my questions :)

Link to comment
Share on other sites

19 hours ago, ShaneDT said:

GregA so you have the latest version ESMC server and the latest version of the agent installed on your client computers and you're still getting the warning message? 

Update: One of our techs was working on this over the weekend and he says that he found the old Kaspersky A/V agent (our previous A/V provider) was still installed and after uninstalling the old Kaspersky A/V agent the "ESET Management Agent is outdated" message went away. He did this fix on about 30 workstations.

Link to comment
Share on other sites

  • Administrators

A notification about outdated agent is shown in Endpoint's gui. If you upgrade the agent to v7.2, the notification may remain displayed until the next computer restart. In case it was displayed even after the restart, try restarting the machine by running the command "shutdown -r -t 0".

Link to comment
Share on other sites

Hi Marcos,

So you recommend go straight to the latest version using Client Task / SMC Components Upgrade? Just run it, let it finish and I guess restart the server? Nothing else to do?

Will I have any issues if any of the client computers are running an older version of the agent (all 7.0 or above, most are already 7.2)?

Do I also need to upgrade Apache or is this upgraded along with Components Upgrade?

If not is there documented process to upgrade Apache? 

Are there any other components that need to be separately upgraded on the server?

Link to comment
Share on other sites

  • Administrators

Yes, in order to upgrade the ESMC server to v7.2 it's enough to send an ESMC component upgrade task to the server.

As for which components are upgraded with the task and which are not, please read https://help.eset.com/esmc_install/72/en-US/components_upgrade.html with links to instructions how to upgrade those components.

Link to comment
Share on other sites

  • Administrators

I'm sorry, I've edited my post. The instructions are same - send an ESMC upgrade component upgrade task to the server.

List of upgraded components:

  • ESMC Server
  • ESET Management Agent
  • ESMC Web Console - only applies when Apache Tomcat was installed to its default installation folder in both Windows and Linux distributions, including ESMC Virtual Appliance (for example: /var/lib/tomcat8/webapps/, /var/lib/tomcat7/webapps/, /var/lib/tomcat/webapps/).
  • ESMC Mobile Device Connector. We recommend that you upgrade MDM to version 6.5 before upgrading your environment to version 7.2.

 

If you want to upgrade all components, please refer to the help:

Components that must be upgraded manually:

Link to comment
Share on other sites

Thanks Marcos. 

Final question that hasn't yet been answered, and is potentially pretty critical.

If I upgrade the server to the latest version, will I have any issues if any of the client computers are still running an older version of the agent (all 7.0 or above, most are already 7.2)? Will they still connect OK?

Link to comment
Share on other sites

  • Administrators
3 hours ago, ShaneDT said:

If I upgrade the server to the latest version, will I have any issues if any of the client computers are still running an older version of the agent (all 7.0 or above, most are already 7.2)? Will they still connect OK?

Yes, even machines with agent 6.x would connect to the ESMC server. However, in order to take advantage of all new features, such as the network isolation task, agent needs to be updated to v.7.2.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...