Jump to content

OpenVAS web login gives me eset SSL_ERROR_BAD_CERT_ALERT


Recommended Posts

Hi,

I am trying the openVAS tryout in a virtual machine as they suggested on their site.

But eset and firefox is preventing me from accessing it.  I am getting:

   Secure Connection Failed

   An error occurred during a connection to "IP address" SSL peer cannot verify your certificate. Error code: SSL_ERROR_BAD_CERT_ALERT

I think the virtual machine is a linux and it uses a self-signed SSL certificate.

Is there a way to add an exception in eset for a web site that I trust?

Link to comment
Share on other sites

  • Administrators

In the advanced setup ->  Web and email -> Protocol filtering, you can exclude applications or IP addressed from protocol filtering.

Link to comment
Share on other sites

Hi,

I am trying what you suggested but:

1- I could not find your option 'Protocol filtering'.

2- I could only find 'advanced setup -> web and email -> web access protection -> url address management' that has an address list that I can edit.

I added the IP address in the 'list of allowed addresses' and clicked ok to confirm.

But that does not help.  I am still getting the same error message.

Link to comment
Share on other sites

An alternative approach is to exclude the certificate associated with domain(URL) from SSL protocol scanning.

The below screen shot shows how to do so. Best way to add the certificate for exclusion is to set SSL protocol filtering mode to Interactive. Then access the HTTPS web site. Eset will ask you to block or allow the certificate associated with the web site - select "allow" for access action. Then, additionally select "ignore" for scan action. Finally, reset SSL protocol filtering mode to Automatic.

Eset_Exclude_Cert.thumb.png.429a078344345e290b8eb33faac499f5.png 

Edited by itman
Link to comment
Share on other sites

Thanks for your help.

I tried both your suggestions.

1- When I "set SSL protocol filtering mode to Interactive", I cannot even access this forum. I am getting that same error SSL_ERROR_BAD_CERT_ALERT.

2- So I tried adding the ip address in the 'list of known certificates' but it does not seem to help when I "set SSL protocol filtering mode to Interactive".  Eset does not ask me anything even though the option is set to 'interactive' and the certificate was added in the list with 'Auto'. 

eset.png.9f29c536bc2139b7d315eb373bf0604a.png

So I have put it back to 'automatic' and changed the access to 'Allow' and 'Ignore' and it seems to have worked through Firefox adding the exception for that address.

Edited by virtualpaul
Link to comment
Share on other sites

1 hour ago, virtualpaul said:

So I have put it back to 'automatic' and changed the access to 'Allow' and 'Ignore' and it seems to have worked through Firefox adding the exception for that address.

Post a screen shot of what is currently shown in "List of know certificates."

Link to comment
Share on other sites

Just that you're aware of this, any localhost HTTPS connection; i.e. 127.0.0.0 - 127.255.255.255, using this certificate will not be scanned for malware via Eset's SSL protocol scanning feature.

Link to comment
Share on other sites

I used the eset menus to enter a specific IP address (192.168....) but it saved 'localhost' so I am not sure what I can do.

I don't like this at all but is there another option?

Edited by virtualpaul
Link to comment
Share on other sites

33 minutes ago, virtualpaul said:

I don't like this at all but is there another option?

If this certificate is related to a specific internal IP address as you posted, you can try to exclude SSL protocol scanning for that IP address as shown by the below screen shot. Add the IP address to the Excluded IP addresses section. Before doing this, you will have to first delete the existing List of known certificates entry.

Then test to see if this solves you problem.

-EDIT- Note this disables all of Eset's web filtering protection for this IP address.

Eset_Exclude_IP_Address.thumb.png.71066715dfd8b5f0d67045fa989a2961.png

Edited by itman
Link to comment
Share on other sites

So it would seem that either way I am opening some security holes.  I am not sure which one is worse.

Is there a way to just accept that self-signed SSL certificate without opening new security holes?

Link to comment
Share on other sites

You could try to use the "File" option to add the certificate to the List of know certificates as shown by the below screen shot. First of course your would have to export the cert. using certmgr.msc option.

I have never used this option. "My gut" tells me you will end up with an entry identical to the existing one. That is Name and Issuer will be set to "Localhost." So what you have presently might be your best option. Also Eset doesn't explain what "Localhost" means in this context. It might just mean ignore scanning any HTTPS communication that uses this certificate which I believe is what you want.

Eset_Cert_Load.thumb.png.9318e2b4d3ebdc014bdd5e62a2d5a790.png

 

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...