Jump to content

Archived

This topic is now archived and is closed to further replies.

mar122999

Banking and Payment Protection Issue

Recommended Posts

Windows 10 x64 , Eset 11.54 (tried pre-release updates), Chrome 67

Hi. I was wondering why ESET Banking and Payment Protection doesn't auto load on popular US sites such as (I know I can add them manually):

chase.com
paypal.com
capitalone.com
coinbase.com
tdameritrade.com

Also, why the limited support on extensions for password managers in Banking Protection? Ones I've had problems with are:

Sticky Password
Dashlane

Ones that have worked: Roboform

Anyway, it would seem at ESET would stay on top of things such as this. Especially something as simple such as white-listing and auto loading the sites above. Why does this feature feel half baked?

I'm not trying to rag on ESET, only curious on why? Thanks for your time.

P.S. I understand the security flaws extensions can bring, but they can't all be that bad. Banking protection is unusable without a password manager being allowed, especially considering (I've heard) ESET uses Sticky Passwords technology to run their own PW manager (which is allowed).

Share this post


Link to post
Share on other sites
23 hours ago, mar122999 said:

Also, why the limited support on extensions for password managers in Banking Protection? Ones I've had problems with are:

Sticky Password
Dashlane

not sure whether dashlane is a typically supported pw manager (gave up on it a while ago) but it seemed like eset needs to release updated banking protection modules to keep up with supported pw mgrs; this is part of why i've given up on banking protection altogether.

Share this post


Link to post
Share on other sites

Further to Banking issues, I have just started to have a problem with logging into my internet Bank account using the ESET Banking and Protection mode. The number pad on the right hand side of the key pad puts the wrong numbers in account details, and then once in the account all the number keys on the total pad also appear as random numbers not what you key in. I have raised this with my Bank IT people and they have checked it out from their side and it's not a problem from their end. They have helped me with a work around in the short term for the problem but its not ideal. I like the ESET system and have used it for 10 years and this is the first issue I have had. Has anyone had this problem and know how to fix?

Share this post


Link to post
Share on other sites
8 hours ago, Triple42 said:

The number pad on the right hand side of the key pad puts the wrong numbers in account details, and then once in the account all the number keys on the total pad also appear as random numbers not what you key in.

Have you tried using the numeric keys at the top of the keyboard?

Share this post


Link to post
Share on other sites

Using the numeric keys at the top of the keyboard should help if it's Windows XP with ESET v9. It's a known issue which will be addressed in a new build of v9 shortly. If you are using a newer OS than Windows XP,  please upgrade to the latest v11.1.54.

Share this post


Link to post
Share on other sites

Hi, I'm an Eset reseller and have various versions of Eset Home & Business products installed over mutiple clients.

I too have now seen this issue whereby the Banking & Protection feature interferes with the entry of numbers. The first time i encountered it (EIS / Win10 Pro) the client could not enter numbers into their internet banking site using either the number pad or those at the top of the keyboard. However, i noticed Eset had recently installed an update and was suggesting the PC should be re-started. After doing this the issue was resolved.

Last week i installed Eset Internet Security on a Windows 10 Home pc. Immediately the client found they couldnt get into their two banking sites becuase they couldn't get the correct numbers on screen. I assisted via Teamviewer and observed that the 1st number typed woul dbe correct then the 2nd number would appear as "." and from that point on the number appearing on screen was the previous key pressed, for example if the client typed 123456 the characters on screen would be 1.2345. Other observation were the issue occured in Chrome and Internet Explorer but not Edge (because the Eset Banking & Protection doesn't function in Edge). I disabled Banking & Protection and then it worked fine in all browsers. Unfortunately, in this case EIS is claiming it's fully up to date (v10.1.245.0) so i have not been able to resolve it. One final oberservation, if i typed the numbers (via Teamviewer) all was well, so it only seems to effect the local keyboard.

What's the story with this issue as it appears to be occuring more often? Why is it happening? Is there a proper fix coming, if so when? Is there any work around other than disabling Banking Protection or using Edge?

thanks

Share this post


Link to post
Share on other sites
2 hours ago, StanleyES said:

EIS is claiming it's fully up to date (v10.1.245.0)

If you installed v10 using the standard Live installer and not using msi, it should offer you upgrade to the latest v11.1.54. Please uninstall it, download the EIS installer from ESET's website and install it. Should the problem persist, gather logs with ELC and provide me with the generated archive via a personal message.

Also check if running a secure browser via the shortcut on your desktop makes a difference.

Share this post


Link to post
Share on other sites

OK, thanks Marcos, i will try both suggestions and report back

Share this post


Link to post
Share on other sites
12 hours ago, StanleyES said:

... the 1st number typed would be correct then the 2nd number would appear as "." and from that point on the number appearing on screen was the previous key pressed ... What's the story with this issue as it appears to be occurring more often? Why is it happening? Is there a proper fix coming ...

Same here on some computers running windows 7 professional 64 bit and ESET Smart security 9.0.402.0

I suppose it comes down to: how long is ESET software maintenance for each software version?

Share this post


Link to post
Share on other sites
7 hours ago, Patch said:

Same here on some computers running windows 7 professional 64 bit and ESET Smart security 9.0.402.0

I suppose it comes down to: how long is ESET software maintenance for each software version?

See https://support.eset.com/kb3678/

A newer version of v9 addressing this issue will be released soon. For maximum protection we strongly recommend using the latest version, currently 11.1.54.

Share this post


Link to post
Share on other sites

OK, so i uninstalled EIS 10.1.245.0 and installed EIS 11.1.54 using the live installer and it's now OK. - Thanks Marcos

In case it helps anyone i also put in a support request to Eset UK and they told me it can also occur if you have Trusteer Rapport installed. (Commonly pushed by UK banks). The PC i was having trouble with didn't have Rapport but it's worth knowing. They also told me there was a new version of the banking module (version 1333) which might fix the issue but the computer thats now OK is still on 1332.

Share this post


Link to post
Share on other sites
35 minutes ago, StanleyES said:

In case it helps anyone i also put in a support request to Eset UK and they told me it can also occur if you have Trusteer Rapport installed.

Trusteer Rapport is not compatible with most if not all AV products with a Banking and Payment Protection feature. You either use TR or the AV product's BPP feature exclusively.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...