Jump to content

SNMP TRAPS


D4rius
 Share

Recommended Posts

Hello using , I created few notifications which should send a snmp trap, but somehow it doesn't so what I tried was:

  1. To send notifications to logs, email, and snmp trap but none came.
  2. Also I tried to send snmptrap from eset cli to my zabbix server and everything seems fine.
  3. Tried diferent configurations of notification itself (my notification is set to alert about dynamic group changes)
  4. Tried diferent snmp.conf and snmptrapd.conf settings but none helped

So my question is it possible to send snmp traps from ERA to zabbix? How to do that? and where I can find appropriate logs for troubleshooting because all necessary services is running and manual snmptrap test passes. Read lots of documentation but am I missing something?

Help would be deeply appreciated :)

 

Using ESET Remote Administrator (Server), Version 6.5 (6.5.417.0)

Edited by D4rius
Added era version
Link to comment
Share on other sites

  • ESET Staff

SNMP traps are sent by ERA to localhost, therefore forwarding has to be configured, as described in documentation.

Regarding your issue, it seems that notification is not triggered at all. I would recommend to tweak it using email as it is much easier to setup and diagnose. In case you have properly set SMTP server parameters (and you are able to receive test email), it is almost 100% that notification is not triggerd - is it one of predefined, or newly created?

Link to comment
Share on other sites

I have tried predefiend and newly created notifications and tried to send them via emai+snmp trap+log server, but none seems to work.

I attach pictures of my newly created notification config. My dynamic group was predefined and no changes were made to it. So as I understand when for example I delete one of my OSX computers system should send notification rigt? or am I wrong? And when eset rediscovers it once again notification should be sent?

And on server side I'm using Cent os, so I dont have  /etc/default/snmpd file , so should I create new one?

and snmpd.conf file should only contain those 3 lines? 

rocommunity public
syslocation "Testing ERA6"
syscontact admin@ERA6.com

If I send trap from eset server for example: snmptrap -v 1 -c public 127.0.0.1 '.1.3.6.1.6.3.1.1.5.4' '0.0.0.0' 6 33 '55' .1.3.6.1.6.3.1.1.5.4 s "eth0"

I receive it on my zabbix server (using different ip not localhost).

a.PNG

b.PNG

c.PNG

Edited by D4rius
Link to comment
Share on other sites

  • 1 month later...
  • ESET Staff

Hello @D4rius,

It looks that something is wrong with the server configuration, if the notifications are not triggered. I would suggest that you contact your official ESET Support representative (partner from which you have purchased the license), and proceed using the standard support workflow (ticketing) procedure.

Edited by MichalJ
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...