jvthert

Eset GUI forces macbook to discrete GPU

Recommended Posts

On MacBooks that have a dual GPU (Intel HD/Iris and Nvidia or AMD) the 'esets_gui' process forces the system to use the discrete gpu as soon as you either click on the tray icon or open the gui. After closing it the GPU is still forced into discrete mode.

 

The problem is that this severely impacts battery life for no apparent reason. This issue is very easy to reproduce but you need gfxcardstatus (hxxp://gfx.io) to see this.

 

The only solution to save your battery is to issue a 'sudo killall esets_gui' in order to force a restart of the process. As long as you stay away from the gui the systems keeps working with the integrated gpu.

 

I tried reporting this to eset support but it seems they are more concerned making this process a pain in the butt. Worst was that support claimed having tried to reproduce it but this is a blatant lie. I've reliably reproduced this bug on different MacBooks. I hope someone here can chime in or relay it to product development.

post-14597-0-11952600-1479902233_thumb.png

Share this post


Link to post
Share on other sites

I am looking for the same solution, i would love to keep running it in the background but i just can't afford it due to the severe battery impact. 

Share this post


Link to post
Share on other sites

I am having the exact same issue. I had contacted support before but they insisted it was due to my environment. Clearly that isn't the case. Hopefully Eset fixes this soon or I will probably switch to another product.

Share this post


Link to post
Share on other sites

I was having the same issue. Hopefully this gets fixed soon

Share this post


Link to post
Share on other sites

Temporary workaround until ESET fixes this: Add the property as described in: https://developer.apple.com/library/content/qa/qa1734/_index.html

 

At own risk: 

 

1. Close ESET Antivirus

2. Open Terminal

3. Navigate to correct folder: "cd /Applications/ESET\ Cyber\ Security\ Pro.app/Contents/"

4. Open Info.plist: "sudo nano Info.plist"

5. Scroll to botom and before the final /dict add the following: 

        <key>NSSupportsAutomaticGraphicsSwitching</key>

        <true/>

6. Hit ctrl+x to quit and and y to save. 

7. Restart ESET and notice how it only uses iGPU now :)


Share this post


Link to post
Share on other sites

Great! I'll give that a go. Btw it's not just the eset_gui, it's also the eset_tray process that triggers the discrete gpu!

Share this post


Link to post
Share on other sites

Hi,

 

I am also having this issue. I find as soon as I click on the icon in the top menu the discrete graphics card is activated. If I don't attempt to open ESET, it stays on the integrated graphics.

 

I did contact support and was told to submit some diagnostic logs, which I did back in September, and I haven't heard any more. Not impressed.

 

Hopefully ESET fix this soon as its really annoying and makes it the product unusable.

Share this post


Link to post
Share on other sites

Was this issue ever resolved?  Seeing lots of questions in the Eset MAC forum that have ZERO answers or replies.

Share this post


Link to post
Share on other sites

Are you having the issue even after upgrading to MacOS Sierra 10.12.3 ?

Share this post


Link to post
Share on other sites

We've got some reports that upgrading to the latest version macOS Sierra 10.12.3 resolved the issue, hence the question as nobody has mentioned the version of the OS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.