Jump to content

Problems with Era 6 installed on centos 6.7


fei
 Share

Recommended Posts

I have an issue with the the latest Era server installed on Centos 6.7

The issue seems like a problem with Mysql connection.

 

In the server trace.log i get this message

Error: CCleanupModule [Thread 7f256d9e8700]: [MySQL][ODBC 5.3(a) Driver][mysqld-5.7.10]Expression #1 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'era_db.a.SourceUuid_id' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by
 

Anybody out there who knows how i can sort this issue?

 

Regards,

Fei

 

Link to comment
Share on other sites

  • Administrators

It is caused by sql_mode value being incompatible with ERA:

Workaround: disable ONLY_FULL_GROUP_BY mode. Then add or edit the value in the configuration file and eventually restart MySQL daemon:


As of MySQL 5.7.5, the default SQL mode includes ONLY_FULL_GROUP_BY. (Before 5.7.5, MySQL does not detect functional dependency and ONLY_FULL_GROUP_BY is not enabled by default. For a description of pre-5.7.5 behavior, see the MySQL 5.6 Reference Manual.)

 

 

[mysqld]

sql-mode=STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

Link to comment
Share on other sites

Hi Marcos,

I have tried to edit the my.cnf in /etc but i still get the same error.

Is it sql-mode or sql_mode?

 

when i do a select @@sql-mode; i see the mode is enabled without only_full_group_by but i just dont understand why.

Maybe there's another file that i need to edit?

 

Thanks!

Link to comment
Share on other sites

  • ESET Staff

Hi Marcos,

I have tried to edit the my.cnf in /etc but i still get the same error.

Is it sql-mode or sql_mode?

 

when i do a select @@sql-mode; i see the mode is enabled without only_full_group_by but i just dont understand why.

Maybe there's another file that i need to edit?

 

Thanks!

 

Please follow this: hxxp://dev.mysql.com/doc/refman/5.7/en/sql-mode.html#sql-mode-changes, when set in my.cnf it should be  sql-mode , but there is also command line parameter --sql_mode that can be used to override configuration - but this depends on how your MySQL daemon is being started.

 

In case you wont be able to make it work, I would suggest to downgrade database to MySQL 5.6 that is fully supported by ERA. You are using database that was released later than testing of latest ERA has begun.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...