Jump to content

Personal firewall problems


Recommended Posts

I just installed ESET and I'm frustrated that the firewall blocks all my browsers. This is rediculous and never has happened with any other security suite. I had to go through the process of creating rules for all three. Why is this happening? Isn't ESET suppose to automaticallh identifh and applh appropriate rules?

Link to comment
Share on other sites

  • Administrators

Didn't you create custom rules to block the communication? If you open the firewall rule editor, does disabling any custom rules at the end of the list make the problem go away?

Link to comment
Share on other sites

Didn't you create custom rules to block the communication? If you open the firewall rule editor, does disabling any custom rules at the end of the list make the problem go away?

Thanks for your reply.

On the contrary I had to create custom rules for all three browsers in order to be able to connect to the internet--after installation, access was denied.  I thought it was supposed to be a smart firewall.

Link to comment
Share on other sites

  • Administrators

Everything should normally work after installation of ESS, especially browsers unless the communication is blocked by custom rules or an incorrect type of network, if selected upon new network detection.

Open the advanced setup, navigate to Network -> Personal firewall -> Rules and zones and click the first Setup button in the Trusted zone section. Make sure the network is trusted (home/work network).

Link to comment
Share on other sites

Everything should normally work after installation of ESS, especially browsers unless the communication is blocked by custom rules or an incorrect type of network, if selected upon new network detection.

Open the advanced setup, navigate to Network -> Personal firewall -> Rules and zones and click the first Setup button in the Trusted zone section. Make sure the network is trusted (home/work network).

Do you mean that all I had to do is choose "home/work network" and everything should have been OK?

Link to comment
Share on other sites

  • Administrators

Do you mean that all I had to do is choose "home/work network" and everything should have been OK?

Hard to say but it could help. Selecting public network will block certain network communication to protect your computer from possible attackers. However, if you are in a home network (ie. a network you trust), you should select Home network to make communication with devices in your LAN possible.

Link to comment
Share on other sites

Perhaps the firewall filtering mode got set to Interactive versus the default Automatic mode? In Automatic mode, all outbound traffic is allowed.

 

I have run with Public profile since day 1 and never had an issue with outbound traffic with firewall set to Automatic mode.

 

Perhaps the issue is with inbound traffic to your browsers for some reason? If so, this might be DNS related. Hopefully, you did not create firewall rules to allow inbound traffic to the browsers?

Link to comment
Share on other sites

Perhaps the firewall filtering mode got set to Interactive versus the default Automatic mode? In Automatic mode, all outbound traffic is allowed.

 

I have run with Public profile since day 1 and never had an issue with outbound traffic with firewall set to Automatic mode.

 

Perhaps the issue is with inbound traffic to your browsers for some reason? If so, this might be DNS related. Hopefully, you did not create firewall rules to allow inbound traffic to the browsers?

Norton by default allows both inbound and outgoing access for browsers. Why woudn't you recommend these settings? By the way, my settings are set to automatic.

Link to comment
Share on other sites

 

Perhaps the firewall filtering mode got set to Interactive versus the default Automatic mode? In Automatic mode, all outbound traffic is allowed.

 

I have run with Public profile since day 1 and never had an issue with outbound traffic with firewall set to Automatic mode.

 

Perhaps the issue is with inbound traffic to your browsers for some reason? If so, this might be DNS related. Hopefully, you did not create firewall rules to allow inbound traffic to the browsers?

Norton by default allows both inbound and outgoing access for browsers. Why woudn't you recommend these settings? By the way, my settings are set to automatic.

 

If Eset firewall filtering mode is set to Automatic, then all outbound traffic is allowed as far as Eset is concerned.

 

By any chance did you every change the WIN firewall default settings in the past? Like along the lines of enabling outbound firewall processing? And additionally creating any rules there for your browsers? Is the WIN firewall set to the Home or to the Public profile?

 

Also is the only outbound traffic that is being blocked for your browsers or is all outbound app traffic being blocked?

 

Finally, did you uninstall all other security software and run their respective clean utilities prior to installing Eset? Are you running any other security software besides Eset?

Edited by itman
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...