Jump to content

Eset Firewall Interactive Mode doesn't work after upgrade to v. 14.1.19


Recommended Posts

Posted (edited)

i can confirm the firewall is a mess since the latest version upgrade... when in interactive mode it's randomly blocking whitelisted applications

Edited by pukko
typo
Link to comment
Share on other sites

  • Administrators
9 hours ago, pukko said:

i can confirm the firewall is a mess since the latest version upgrade... when in interactive mode it's randomly blocking whitelisted applications

Are you able to reproduce it after uninstalling ESET, installing the latest version from scratch and switching the firewall to interactive mode?

Link to comment
Share on other sites

  • Administrators
11 hours ago, pukko said:

yes, i have tried everything i could

I'd recommend raising a support ticket with your local ESET distributor if you can easily reproduce the issue after a clean install with default settings and switching the firewall to interactive mode.

Link to comment
Share on other sites

  • ESET Insiders
Posted (edited)

Eset Firewall is not working for me either in Interactive Mode after updating to Eset version 14.1.20.0. I'm not sure if this bug affects the other modes. The problem only occurs when an application updates; Eset does not detect changes have occurred to the application that has updated. Eset gives no prompt informing the user that changes have occurred to the application that has updated. Then when trying to use the application that has updated again, Eset silently blocks that application from accessing the Internet. This has happened to me with all application that have updated so far, Firefox, Waterfox, Torrent Clients, etc..

In order to fix the problem I had to go to advanced firewall rules, and delete the rule for the applications that updated from Eset. Then I had to try using the application again to see if Eset would give me a prompt again for the updated application's attempt to access the Internet. If Eset still was unable to detect the application's attempt to access the Internet, then I had to reboot my system. Eset was then able to detect the application's attempt to access the Internet and gave me the option to create a new firewall rule for the application.

I'm using Windows 10x64 Pro 20H2, Eset version 14.1.20.0.

Edited by cutting_edgetech
Link to comment
Share on other sites

  • Administrators
33 minutes ago, cutting_edgetech said:

Eset Firewall is not working for me either in Interactive Mode after updating to Eset version 14.1.20.0. I'm not sure if this bug affects the other modes. The problem only occurs when an application updates; Eset does not detect changes have occurred to the application that has updated. Eset gives no prompt informing the user that changes have occurred to the application that has updated. Then when trying to use the application that has updated again, Eset silently blocks that application from accessing the Internet. This has happened to me with all application that have updated so far, Firefox, Waterfox, Torrent Clients, etc..

In order to fix the problem I had to go to advanced firewall rules, and delete the rule for the applications that updated from Eset. Then I had to try using the application again to see if Eset would give me a prompt again for the updated application's attempt to access the Internet. If Eset still was unable to detect the application's attempt to access the Internet, then I had to reboot my system. Eset was then able to detect the application's attempt to access the Internet and gave me the option to create a new firewall rule for the application.

I'm using Windows 10x64 Pro 20H2, Eset version 14.1.20.0.

Hm, this was supposed to be already fixed. Does switching to the pre-release update channel and updating the program to v14.2 make a difference?

Link to comment
Share on other sites

  • ESET Insiders
Posted (edited)
1 hour ago, Marcos said:

Hm, this was supposed to be already fixed. Does switching to the pre-release update channel and updating the program to v14.2 make a difference?

I enabled prerelease updates and installed Eset Smart Security Version 14.2.10.0, but it may be a while before I know if that fixed the problem. I just updated all the applications on my machine yesterday, and I will have to wait until there are application updates to install before I can see if installing prerelease updates fixed the problem.

Edited by cutting_edgetech
Link to comment
Share on other sites

  • Administrators

Should the problem persist, please generate an ekrn dump via the adv. setup -> tools -> diagnostics -> create when an interactive dialog is supposed to pop up and then collect logs with ESET Log Collector.

Link to comment
Share on other sites

  • 2 weeks later...

Same problem. Interactive mode doesn't work. No notifications are shown. Learning mode creates new rules and those are favored, but Interactive mode effectively = policy based. 

Link to comment
Share on other sites

  • Administrators
6 hours ago, angelspire said:

Same problem. Interactive mode doesn't work. No notifications are shown. Learning mode creates new rules and those are favored, but Interactive mode effectively = policy based. 

Do you have v14.2 installed? Do you have Gamer mode turned off?

Do you have interactive alerts enabled?

image.png

Link to comment
Share on other sites

This isn't fixed for me either. With the normal release I would get interactive firewall prompts for the first day but as soon as I put my computer to sleep and then wake it up they would stop. I updated Firefox and a game and they wouldn't connect to the internet since it wouldn't give me a prompt about things changing and I had to restart to get the prompts.

I tried uninstalling and re-installing and that made no difference. I then switched to pre-release and then I was able to put my computer to sleep and still get interactive firewall prompts the next day after waking it up. But so far every time by the third day after putting it to sleep I no longer get interactive firewall prompts until I restart.

Gamer mode is paused and Interactive Alerts is enabled. This isn't an issue I've had before with using ESET for years.

Link to comment
Share on other sites

  • 3 weeks later...

Same problem here with version 14.2.19.0 under Windows 10 Pro (Build 1909)!
I tried with gaming mode off and checked notification configuration to no avail.
I deleted every rule, but nothing pops up in interactive mode.

On another machine with version 14.1.20.0 under WIndows 10 Pro (Build 1909) this does not happen.

Link to comment
Share on other sites

  • Administrators
3 hours ago, Betatesta said:

On another machine with version 14.1.20.0 under WIndows 10 Pro (Build 1909) this does not happen.

Please re-test it with v14.2.20+ when available.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...