Jump to content

Mobile Device Enrollment sending ip

Recommended Posts


I configured MDM appliance and added my winldcard pfx to tomcat, everything green and ok.

In ESMC Appliance, i also made a certificate setting and password en i get the appliance on its correct hostname in the computer list.

(set the date in de passed and tried like 3 minutes in futre, i have no devices enrolled its first setup)

on the appliance the mdm appliance stays red more on this later

When i send out a enrollment e-mail i get a link with the appliance ip in the mail, not the fqdn and offcourse then i get an certificate error its not on ip.


The appliance is red because it says " MDM hostname does not match HTTPS certificate " but the fqdn is correct and if i connect with it green and ok

I tried set the policy organisation (hostname no longer there) to my server name, and because of it's a wildcar also tried only domain. its is *.domain.com and de mdm is hostname.domain.com else i would not get a green certificate when i connect to https://hostname.domain.com:9980/ 

If i look up the warning i mostly find its a feature, i can no where in de esmc set the hostname (or find it) 


and again when i enroll i get a link in the e-mail https://<ip adress appliance>:9980/<device id> 

and offcourse then the users get a certificate warning. how or where can i change it to fqdn and not ip?


Kind Regards,


Link to comment
Share on other sites

  • ESET Staff


Hostname is stored in MDM configuration.

We sadly removed configuration option for hostname in policy (as some users broke their MDM by changing it), so currently only supported way to change hostname is reinstallation (or repair).



Edited by Mirek S.
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...