Jump to content

HIPS communication with the driver failed


siljaline
 Share

Recommended Posts

Hello,

Just upgraded from 4x to 5x and see this in log files - >  events

08/02/2014 7:42:50 PM HIPS Communication with the driver failed. HIPS does not work

HIPS shows as being enabled via screen capture - should I be concerned ?

 

 


.   

post-63-0-94406400-1391913724_thumb.png

Link to comment
Share on other sites

  • Administrators

A computer restart is required after an upgrade for new drivers to load. Perhaps the error is from a time when the computer wasn't restarted yet.

Link to comment
Share on other sites

A computer restart is required after an upgrade for new drivers to load. Perhaps the error is from a time when the computer wasn't restarted yet.

This was post reboot. HIPS is currently enabled in advanced setup. My installed components for your perusal in the event you may want to see them.

 

Virus signature database: 9399 (20140208)

Rapid Response module: 3667 (20140208)

Update module: 1047 (20131023)

Antivirus and antispyware scanner module: 1419 (20140122)

Advanced heuristics module: 1147 (20140114)

Archive support module: 1188 (20140107)

Cleaner module: 1082 (20140110)

Anti-Stealth support module: 1057 (20131125)

ESET SysInspector module: 1240 (20131202)

Self-defense support module: 1018 (20100812)

Real-time file system protection module: 1006 (20110921)

Translation support module: 1145 (20131121)

HIPS support module: 1110 (20140121)

Internet protection module: 1101 (20140122)

Database module: 1046 (20131204)

 

Link to comment
Share on other sites

  • Administrators

Do you mean you're still getting this error after the computer was restarted? The protection status seems to be green so HIPS must be protecting your computer.

Link to comment
Share on other sites

Do you mean you're still getting this error after the computer was restarted? The protection status seems to be green so HIPS must be protecting your computer.

Yes - the error was seen one time post installation. HIPS is now working as there have been no events logged of this type since several additional reboots.

Appears to be fine for now but I'm going to leave the open as it may be a teething problem and not much else. Will report back as soon as I spot something.

Link to comment
Share on other sites

Windows Reliability History shows an unsuccessful installation as noted - the latter was successful - I suspect this was what caused the event flag.

Windows Installer installed the product. Product Name: ESET Endpoint Antivirus. Product Version: 5.0.2225.0. Product Language: 1033. Manufacturer: ESET, spol. s r.o.. Installation success or error status: 1602.

 

Link to comment
Share on other sites

  • 2 weeks later...

any updates to this? Have you found your HIPS is working on the client workstation? I have recently upgraded my own workstation from nod32 4 to endpoint antivirus(ver 5) and got the exact same error message as you, only once. I rebooted and haven't seen anything since. Just wondering what else i need to check to make sure this is working before i start rolling out updates to my other clients' workstations.

 

also, how do you view the installed components? 

 

thanks.

Link to comment
Share on other sites

  • Administrators

It is pretty normal and expected that you'll get this error after an upgrade, before restarting the computer. A computer restart is required for the HIPS driver to get loaded so that ekrn can communicate with it.

Link to comment
Share on other sites

It is pretty normal and expected that you'll get this error after an upgrade, before restarting the computer. A computer restart is required for the HIPS driver to get loaded so that ekrn can communicate with it.

 

10-4 thanks for the feedback. I just wanted to make sure this was correct before proceeding with push installations of other clients. Once i restarted my workstation, i did not get another error and my HIPS said enabled inside the antivirus program. Thanks for your help. 

Link to comment
Share on other sites

  • 1 month later...

You should go into Advanced Setup and check the HIPS status there.  All forty some clients of mine are showing this error in Remote Administrator and under Advanced Setup there is a red dot next to HIPS.  I have tried uninstalling/rebooting/reinstall to no avail.  There are threads all over for years with this problem and no clear solution.

 

Virus signature database: 9598 (20140326)
Rapid Response module: 3881 (20140326)
Update module: 1048 (20140204)
Antivirus and antispyware scanner module: 1423 (20140313)
Advanced heuristics module: 1147 (20140114)
Archive support module: 1194 (20140310)
Cleaner module: 1087 (20140317)
Anti-Stealth support module: 1058 (20140130)
ESET SysInspector module: 1240 (20131202)
Self-defense support module: 1018 (20100812)
Real-time file system protection module: 1006 (20110921)
Translation support module: 1145 (20131121)
HIPS support module: 1120 (20140305)
Internet protection module: 1110 (20140228)
Database module: 1057 (20140312)

Link to comment
Share on other sites

Okay, apparently the red dot is not a bad thing.  I updated the package manager to version 5.0.2228.1 and did a fresh install on the test machine and after a reboot the HIPS error does not show up in Remote Administrator but the red dot is still there in Advanced Setup.

 

Virus signature database: 9599 (20140326)
Rapid Response module: 3882 (20140326)
Update module: 1048 (20140204)
Antivirus and antispyware scanner module: 1423 (20140313)
Advanced heuristics module: 1147 (20140114)
Archive support module: 1194 (20140310)
Cleaner module: 1087 (20140317)
Anti-Stealth support module: 1058 (20140130)
ESET SysInspector module: 1240 (20131202)
Self-defense support module: 1018 (20100812)
Real-time file system protection module: 1006 (20110921)
Translation support module: 1145 (20131121)
HIPS support module: 1120 (20140305)
Internet protection module: 1110 (20140228)
Database module: 1057 (20140312)

 

David

Edited by NemecekCole
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...