Jump to content

Archived

This topic is now archived and is closed to further replies.

Matt Gorner

"Not All Required Network Features Are Active" Error

Recommended Posts

ESET Smart Security v10.0.390.0 keeps reporting "Not All Required Network Features Are Active".

When I go to 'Setup' it states:

Personal firewall
Non-functional: filtering of incoming and outgoing network traffic 

Network attack protection (IDS)
Non-functional: detection of incoming network attacks

Botnet protection
Non-functional: detection and blocking of botnet communication

If I click the switch on each of these, I only get the option to disable permanently.  I tried that and clicked again, but it still remains red.

Tried an installation repair, that didn't solve it either.

Checked Windows network settings, and they report that the firewall is being managed by ESET Smart Security.

Any ideas how to solve this?

Cheers
Matt

PC Spec:
Operating system: Windows 7 Professional (64-bit)
Machine: Intel(R) Core(TM) i7 CPU X 980 @ 3.33GHz

Network_Protection_Error_01.png

Network_Protection_Error_02.png

Share this post


Link to post
Share on other sites

Please continue as follows:

- in the advanced setup -> Tools -> Diagnostics, enable advanced firewall logging
- restart the computer
- when the issue occurs, generate a dump of ekrn by clicking the appropriate button in the advanced setup -> Tools -> Diagnostics
- disable advanced logging
- collect logs with ESET Log Collector (see my signature for a link to instructions)
- upload the generated archive to a safe location and pm me a download link.

Share this post


Link to post
Share on other sites

Matt, I had a similar issue.

I went to Eset's main site, downloaded their installer again and re-installed the software. It worked for me and the errors disappeared.

Share this post


Link to post
Share on other sites

There has been a PreRelease of the firewall module since yesterday, which should also solve your error in order to get it you have to change in the settings under Update it to PreRelease so that you can download the PreRelease module of the firewall!

Share this post


Link to post
Share on other sites

I suddenly have exactly the same alarming Personal Firewall, Network Attack Protection and Botnet protection problem as the original poster on this thread, and also only have the "Disable Permanently" drop-down option against each item.

I also notice that the Firewall "Learning Mode Settings" section (and sub-sections) is completely greyed out. I don't know if this is connected to the main problem.

However, the "Home" page of my ESET GUI says everything is OK.

Finally, I find that in Advance Setup\User interface Elements\Application Statuses, the "Personal Firewall dropdown is telling me that Firewall & Botnet Protection are paused AND non functional!

What on earth is happening here? Have I been invaded and my settings changed? I'd taken off the settings password protection function a while ago because it was interrupting so much (for my own good, I know. Stupid me!

Screengrabs attached.

 

 

ESET 1.jpg

ESET 2.jpg

ESET 3.jpg

ESET 4.jpg

Share this post


Link to post
Share on other sites

Please provide me with logs collected by ESET Log Collector as per the instructions linked in my signature. You can also check if the Windows Firewall service is running as it could be one of the reasons why ESET's firewall doesn't start.

Share this post


Link to post
Share on other sites

BTW: The update seems to have fixed my original issue.  I did have to completely uninstall and re-install the program though.

Currently on version 10.1.210.4 of ESET Smart Security, if that helps anyone else.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...