Jump to content

J.J.

Members
  • Content Count

    36
  • Joined

  • Last visited

  • Days Won

    1

J.J. last won the day on May 24

J.J. had the most liked content!

Profile Information

  • Gender
    Not Telling
  • Location
    Slovakia
  1. It work for me when I deleted modules and updated using esets_update. This looks that something else is corrupted or some other issue with download. It is strange if both updates directly from ESET servers. It should work when you clean the cache and modules that all will be downloaded completely fresh.
  2. It is needed to do the following steps to fix the issue because some of the modules are probably corrupted. The best way is to stop the service, clean update cache, delete the modules and download completely fresh update files and modules will be recompiled and added to /var/opt/eset/esets/lib - stop service - delete content of modules directory /var/opt/eset/esets/lib - clean the update cache directory /var/opt/eset/esets/lib/data/updfiles - clean logs direcotry /var/log/esets/ - run update manually deleted modules will be replaced for fresh /opt/eset/esets/sbin/esets_update --verbose - once update is successfully done you can start the service
  3. Disable Selinux (Selinux is not supported by our product): To disable SELinux, configure SELINUX=disabled in /etc/selinux/config: # This file controls the state of SELinux on the system. # SELINUX= can take one of these three values: # enforcing - SELinux security policy is enforced. # permissive - SELinux prints warnings instead of enforcing. # disabled - No SELinux policy is loaded. SELINUX=disabled # SELINUXTYPE= can take one of these two values: # targeted - Targeted processes are protected, # mls - Multi Level Security protection. SELINUXTYPE=targeted Disable Wayland (Wayland is not supported by our product) You can do this on Fedora 29 by editing /etc/gdm/custom.conf and uncommenting the line "#WaylandEnable=false" Install GlibC - yum install libc6.i686 Install Gnome tweak tool: - yum install gnome-tweak-tool Install TopIcons Extension: - yum install gnome-shell-extension-topicons-plus Pre-Requisities: You need the make utility : # Debian, Ubuntu sudo apt-get install make # Red Hat, Fedora sudo dnf install make Download the code to any folder, using git: git clone https://github.com/phocean/TopIcons-plus.git Go into the TopIcons Plus project directory and execute the installation script. cd TopIcons-plus make install This will compile the glib schemas and copy all the necessary files to the GNOME Shell extensions directory for your own user account (so you don't need admin privileges to run make). By default, TopIcons Plus will live in the directory ~/.local/share/gnome-shell/extensions/TopIcons@phocean.net/. If you want to install the extension so that it will be usable system-wide, you'll have to change the INSTALL_PATH variable, and run as root. sudo make install INSTALL_PATH=/usr/share/gnome-shell/extensions Finally, launch the gnome-tweak-tool utility to manage extensions. There, you can enable TopIcons Plus and then tweak its look and feel. Enable Top Icons plus using Gnome Tweak tool - Screenshot attached Install ESET NOD32A Antivirus for Linux Desktop
  4. I checked it at my SLES 12.4 and ESET File Security works for me. I find the cause of the issue. It is that Apparmor is enabled by default at SLES 12.4. It is needed to disable Apparmor completely and reboot the system and than install ESET File Security and it works as expected.
  5. Just for testing purposes can you check if it is working with newest version? It could be interesting to know, if issue is present too with new version. There can be some changes in SLES 12.4
  6. May I ask why are you installing 4.5.11 when 4.5.13 is available? https://www.eset.com/int/business/file-security-linux/download/ - I would suggest to uninstall previous version and make clean install of version 4.5.13 and check if issue persist. reboot system after uninstallation
  7. Here is detailed explanation how to properly install ESET NOD32 Antivirus for Linux desktop at Ubuntu 18.04 To install ESET NOD32 Antivirus for Linux Desktop on Ubuntu 18.04 Open Terminal Set root password using command (sudo passwd root) Install glibc library using command (apt-get install libc6:i386) Install libappindicator1 to show icon in upper tray using command (apt-get install libappindicator1) Download the install package and set the execute privileges Install package, reboot, icon will be shown at upper right corner
  8. Hi mogobjah It looks like some issue with corrupted installation or missing modules. At first check prerequisites which is GlibC: - It is needed to have instaled glibc to run 32bit applications at 64bit os yum install glibc.i686 - check if all modules are present, if some of them are missing it could be the issue. Anyway if they are present some of them can be corrupted somehow and therefore: - Login as root - Stop esets service - create backup folder - Move em00*_32.dat files from /var/opt/eset/esets/lib to backup folder - Run update all modules will be re-created again /opt/eset/esets/sbin/esets_update --verbose - Check content of /var/opt/eset/esets/lib if all modules are present Try to start service and check if issue is fixed or not.
×
×
  • Create New...