Jump to content

J.J.

Members
  • Content Count

    22
  • Joined

  • Last visited


Kudos

  1. Upvote
    J.J. received kudos from Peter Randziak in Eset Business for Linux installs, but does not open in Deepin 15.9.1   
    Hello guys
    Here you can find out how to make it work. Deepin Linux does not met requirements, but anyway by installing all needed libraries you can make it work easily.
    You can find terminal commands in attached screenshots.
    Step 1- First step is to install GlibC
    apt-get install libc6:i386

    Step 2 - Install libappindicator1 to show tray icon after installation
    apt-get install libappindicator1

    Step 3 - Prepare installer download it from ESET webpage, don't forget to choose 64bit installer and grant execute rights

    Step 4 - System does not met requirements and you need to install libgtk libraries
    apt-get install libgtk2.0-0:i386

    Step 5 - But not all libraries are not installed because of distribution issues therefore you need to run it again and use command
    apt-get install libgtk2.0-0:i386 --fix-missing

    Step 6 - So lets go deeper thats why we use Deepin Linux
    Murine libraries for GTK are missing too
    apt-get install gtk2-engines-murine:i386


    Step 7 – Some more engines to install pixbuf
    apt-get install gtk2-engines-pixbuf:i386
     

    Step 8 – We need to install also gnome themes standard
    apt-get install gnome-themes-standard

    Step 9 – And also some extras are needed for gnome themes and therefore we will install gnome-themes-extra, this all are missing
    apt-get install gnome-themes-extra gnome-themes-extra:i386

    Step 10 – We will add architecture i386 for dpkg
    Check architecture
    dpkg –print-architecture
    Add architecture i386
    dpkg –add-architecture i386
    check If architecture was added
    dpkg –print-foreign-architectures

    Step 11 – And now we have optimized environment and we can install ESET NOD32 Antivirus for Linux Desktop



    So, Linux is user friendly but it chooses its friends selectively :)
  2. Upvote
    J.J. received kudos from TomasP in Eset Business for Linux installs, but does not open in Deepin 15.9.1   
    Hello guys
    Here you can find out how to make it work. Deepin Linux does not met requirements, but anyway by installing all needed libraries you can make it work easily.
    You can find terminal commands in attached screenshots.
    Step 1- First step is to install GlibC
    apt-get install libc6:i386

    Step 2 - Install libappindicator1 to show tray icon after installation
    apt-get install libappindicator1

    Step 3 - Prepare installer download it from ESET webpage, don't forget to choose 64bit installer and grant execute rights

    Step 4 - System does not met requirements and you need to install libgtk libraries
    apt-get install libgtk2.0-0:i386

    Step 5 - But not all libraries are not installed because of distribution issues therefore you need to run it again and use command
    apt-get install libgtk2.0-0:i386 --fix-missing

    Step 6 - So lets go deeper thats why we use Deepin Linux
    Murine libraries for GTK are missing too
    apt-get install gtk2-engines-murine:i386


    Step 7 – Some more engines to install pixbuf
    apt-get install gtk2-engines-pixbuf:i386
     

    Step 8 – We need to install also gnome themes standard
    apt-get install gnome-themes-standard

    Step 9 – And also some extras are needed for gnome themes and therefore we will install gnome-themes-extra, this all are missing
    apt-get install gnome-themes-extra gnome-themes-extra:i386

    Step 10 – We will add architecture i386 for dpkg
    Check architecture
    dpkg –print-architecture
    Add architecture i386
    dpkg –add-architecture i386
    check If architecture was added
    dpkg –print-foreign-architectures

    Step 11 – And now we have optimized environment and we can install ESET NOD32 Antivirus for Linux Desktop



    So, Linux is user friendly but it chooses its friends selectively :)
  3. Upvote
    J.J. received kudos from Peter Randziak in Eset Business for Linux installs, but does not open in Deepin 15.9.1   
    Please install libappindicator1 and restart the system, icon should show in tray.
×
×
  • Create New...