Jump to content

CyberSecurity Pro 6.1.12 on Yosemite 10.10.5 Killing SSH


Recommended Posts

So nice to have just spent $150 on CyberSecurity only to have my support question deleted... WTF?!?!?!?  Here it is again, albeit not verbatim as I didn't know the previous post would be deleted.

 

Having a problem connecting via SSH from Mac A to Mac B on my local network.  The CyberSecurity settings are set to Auto-with-exceptions.  Both machines are on my local network.  Both machine's interfaces are set to use profile 'Work', which has as it's first rule 'allow all traffic via local network'.  Randomly a machine will stop allowing SSH with the client reporting "ssh_exchange_identification: Connection closed by remote host" and the server machine logging in the firewall's log 'no usable rule'.  If I reboot the server machine, communications is back to normally until the next time CyberSecurity Pro gets hosed.

 

Can someone from ESET please help?!?!?!?!??!!?

 

 

Best,

guitardood

 

 

EDIT: I apologize for the above complaint about what I assumed was a deleted post.  I didn't realize that new posts were moderated and needed approval and thought my original post was just deleted.   Appreciate the help.

 

EDIT2: Please feel free to delete my original post: https://forum.eset.com/topic/7793-getting-no-usable-rule-trying-to-ssh-from-one-mac-to-another-on-local-network/?p=41714

Edited by guitardood
Link to post
Share on other sites
  • Most Valued Members

Based on your log entry, there is an issue with 6.1.12.0 and the firewall for some connections being automatically denied that I reported since its release, and ESET is aware of this issue. To see if this is the reason for your particular issue, can you try to connect via SSH with the ESET Firewall temporarily turned off (either from the menu bar or in Preferences)? Does it then have trouble connecting again as soon as you turn the firewall back on?

Link to post
Share on other sites

Thanks for the response!!

 

If I disable the firewall, SSH works just fine.  As soon as I reenable the firewall, same issue results (aforementioned ssh error and "no usable rule' log entry).  The only way to resolve the issue and keep the firewall enabled is to reboot the system.  After a reboot SSH works just fine until whatever this bug is triggered again.  FYI, this issue is happening sporadically on both my MacBook Pro and Mac Pro desktop system without any kind of identifiable pattern.

 

Best,

guitardood

Link to post
Share on other sites
  • Most Valued Members

The last thing I would try is to manually create the rules for the SSH, by either entering it yourself or by temporarily setting the firewall mode to Interactive, making the SSH connection and allowing them, then setting the firewall back to Auto with Exceptions.

 

If this still doesn't work, I'm afraid you'll need to wait for ESET to release a fix for this. I'll post a reply to this topic as soon as a fix or update is released as you are following this topic and will get a notification.

 

Depending on your license, you could also temporarily use Cyber Security (not the Pro version) for now and turn on the built in OS X firewall in System Preferences as a workaround (I'm doing this but with Little Snitch installed).

Edited by planet
Link to post
Share on other sites

The last thing I would try is to manually create the rules for the SSH, by either entering it yourself or by temporarily setting the firewall mode to Interactive, making the SSH connection and allowing them, then setting the firewall back to Auto with Exceptions.

 

If this still doesn't work, I'm afraid you'll need to wait for ESET to release a fix for this. I'll post a reply to this topic as soon as a fix or update is released as you are following this topic and will get a notification.

 

Depending on your license, you could also temporarily use Cyber Security (without a firewall) for now and turn on the built in OS X firewall in System Preferences as a workaround (I'm doing this but with Little Snitch installed).

 

Thanks for the advice, Planet.  I had already tried manually adding rules allowing SSH and still received the 'no usable rule' message.

 

As long as ESET is looking into resolving this, I can deal with the occasional reboots until a fix is available.

 

Thanks again for your response and help.

 

Best,

guitardood

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...