Jump to content

Ubuntu 24.04 : issue during the installation of efs


Go to solution Solved by Marcos,

Recommended Posts

Hello ūüĎč

I get an error during the installation of efs on a desktop running Ubuntu 24.04.

Here is the log :

yann@desk01:~$ sudo grep Error /var/log/eset/RemoteAdministrator/Agent/trace.log
2024-04-30 09:47:56 Error: CSystemConnectorModule [Thread 7641384006c0]: SoftwareInstallation: Task execution failed with: SoftwareInstallation: Failed to install binary package '/tmp/9f54-69d3-e6b9-c0d2/efs.x86_64.bin' with exit code: 1, stdout: , stderr: 


The output of the manual installation of that package :

root@desk01:/tmp/9f54-69d3-e6b9-c0d2# apt install ./efs-10.2.41.0.x86_64.deb 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'efs' instead of './efs-10.2.41.0.x86_64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 efs : Depends: linux-headers-generic-hwe-20.04 but it is not installable or
                linux-headers-generic-hwe-18.04 but it is not installable or
                linux-headers-generic-hwe-16.04 but it is not installable or
                linux-headers-amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

 

The dependencies :

root@desk01:/tmp/9f54-69d3-e6b9-c0d2# dpkg -I efs-10.2.41.0.x86_64.deb | grep Depends
 Depends: gcc, make, perl, openssl, tar, nftables, ca-certificates, linux-headers-generic|linux-headers-amd64, linux-headers-generic-hwe-20.04|linux-headers-generic-hwe-18.04|linux-headers-generic-hwe-16.04|linux-headers-amd64, libelf-dev|libelf-devel|elfutils-libelf-devel, libudev1, cron|cronie|systemd-cron, anacron, libsqlite3-0, btrfs-progs, libcurl|libcurl4|libcurl3, libnss3-tools


Ubuntu 24.04 does not seem to have the package linux-headers-amd64

How can I solve that issue ?

Thanks ūüôā¬†

Link to comment
Share on other sites

  • Administrators
  • Solution

According to https://help.eset.com/essl/10.2/en-US/?system_requirements.html, the latest supported version of Ubuntu is 22.04 LTS. Support for 24.04 LTS will be added in the upcoming version of ESET Server Security for Linux which is planned to be released in the following weeks.

Link to comment
Share on other sites

  • 3 weeks later...

some of these so called "following weeks" have already passed and there is still no support for the CURRENT Ubuntu 24.04 LTS server release,  - for a product, that calls itself compatible with "Ubuntu Server".

You should be honest to your customers and change this into:  "Compatible with older versions of Ubuntu Server", but not the most current, and therefore most secure versions of that OS.

I own a license payed till 2026 and I'm not downgrading my server OS version to something outdated, because you missed all the 24.04 beta versions that you could have used to make your security solution compatible.

It's a shame that you behave, as if that new LTS version just popped up completely unexpected and that you now need some weeks, that summed up is now more than a month, to get this most obvious maintenance job done.

Get it done!!

Link to comment
Share on other sites

  • Administrators

We had been actively working on a solution for some time when the final version of Ubuntu 24.04 was released, it is not that we started working on it when it was released. A new version of ESET Server Security for Linux is being prepared and will be released very soon, it's definitely not a matter of weeks but rather days.

Link to comment
Share on other sites

  • Administrators

Yes, it should as it contains the changes and improvements from the latest version of ESET Endpoint Antivirus for Linux, ie:
FIXED: Compilation of eset_rtp and eset_wap fails with latest kernel versions

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...