Jump to content

ESET WAP breaks connection between Docker and RabbitMQ


Recommended Posts

Hello,

we are having problems with ESET on our linux server. After we updated ESET Server Security to 10.1.176.0 the WAP (web access protection) started blocking either communication or the app itself between our linux server that runs Docker and another linux server, that runs RabbitMQ. We even tried excluding both IP addresses from the WAP, but it didn't help. The only logs we get looks like this:


Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6ab70de/phys_port_id with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6ab70de/phys_port_name with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6ab70de/phys_switch_id with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6b2c881/phys_port_id with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6b2c881/phys_port_name with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6b2c881/phys_switch_id with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6c9371a/phys_port_id with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6c9371a/phys_port_name with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6c9371a/phys_switch_id with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6e039fe/phys_port_id with access=1 creation=3, nod_error=11
Dec  8 21:58:41 docker01 oaeventd[1673]: ESET Server Security Debug: Cannot open file /host/sys/devices/virtual/net/veth6e039fe/phys_port_name with access=1 creation=3, nod_error=11
 

After we disabled WAP, everything started working again. Do you have any idea what to do?

We want WAP working on every server but this cannot happen.

Link to comment
Share on other sites

  • 1 month later...
  • Administrators
4 hours ago, Joseph Guay said:

Similar problem. I had to disable web protection.

Please report the issue via a support ticket.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...