Jump to content

Manual install of ESET Management Agent failing - MsiInstaller 1603 error

Recommended Posts

We have client with an Exchange server running Windows Server 2016 and ESET Mail Security (v 10.0.10016.0). Server is fully patched. An automatic update of the ESET Management agent in early August resulted in it losing connection with our ESET PROTECT server (as described in this forum post https://forum.eset.com/topic/37686-eset-management-agent-not-connecting-following-automatic-upgrade-to-vers-10112880/)

To resolve this issue we are attempting to install the ESET Management Agent locally/manually, but the install keeps failing with an MsiInstaller error status of 1603. 

Steps taken so far:
1. Created All-in-one (AiO) installer and attempted local install with that.
2. Uninstalled ESET Management Agent and reattempt install with AiO installer.
3. Restarted server and re-attempt install.
4. Create stand-alone Agent installer (PROTECTAgentInstaller.bat - saved to local folder on server) and attempt install with that.
5. Deleted these folders: C:\Program Files\ESET\EsetRemoteAdministrator; C:\ProgramData\ESET\EsetRemoteAdministrator; and cleared contents of C:\Users\admin.user\AppData\Local\Temp

A review of the ra-agent-install.log (attached) suggests the problem lies with an attempt to access the missing DB file C:\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Data\data.db

Please suggest how to proceed with this issue.


Link to comment
Share on other sites

As per original post, uninstalling the ESET Management Agent was one of the first steps we tried. It is no longer listed in Programs and Features, so if you're seeing evidence of it still being there it must not have uninstalled properly.

Are you proposing that I run the ESET uninstaller (https://support.eset.com/en/kb2289-uninstall-eset-manually-using-the-eset-uninstaller-tool) and select removal of the agent?

It's an Exchange email server so we'll need to organise a scheduled outage with the client, and I just want to check if this is the only course of action before proceeding.

Link to comment
Share on other sites

  • Administrators

Please raise a support ticket. Customer care should provide you with a batch file that will remove all versions of the management agent from the system.

Link to comment
Share on other sites

Hi, we've got the same problem with upgrading / installing the new version of ESET Management Agent 10.1.1292.0 on almost 400 PCs.

When we try to update it from the ESET Protect console, the task finishes successfully, but the Management Agent is not upgraded. When we try it manually - installer end with error - 1603.


Log is attached.


Link to comment
Share on other sites

I have logged a support request for the remover batch file as Marcos suggested (case #00636457). I'll provide an update once I hear back from the Customer Care.

Link to comment
Share on other sites

After chasing up support they responded advising as follows:

Can you create a bat file using the below command and run?
cd C:\Users\Administrator1\Desktop
msiexec /q /x agent_x64.msi PASSWORD=Test123

where the first row determines the folder where the MSI file is and the second row is silent uninstallation with parameter PASSWORD= (if the EM Agent is password protected - if not don't use the parameter) 

Tried this but it made no difference.

@Marcos, is this the batch file you expected them to provide?

I was expecting something similar to the Uninstaller tool, but targeted just at the ESET Agent.


Link to comment
Share on other sites

I ended up running the esetuninstaller.exe tool (from Safe Mode reboot), and selected the option to just uninstall the Agent. I was then able to install the Agent.

The ESET Support contact I dealt with had no knowledge of the ESET Management Agent uninstaller batch file that Marcos referred to.


Link to comment
Share on other sites

  • Most Valued Members

To be fair, it isn't a batch file but a binary executable one.    In order to unhork two of the systems that were using an old version of the Agent, I too had to manually safeboot-run the uninstaller to remove all the ESET products before these two systems would pick up the GPO agent.

Yes, it is a hassle.  I just wish there was some way of uninstalling the agent without needing to physically be at the system.


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...