Jump to content

Cannot get Password Manager to autofill on mobile


Go to solution Solved by Marcos,

Recommended Posts

Hi.  I have Eset Smart Security Premium on 5 PCs and laptops.  It works flawlessly on all and Password Manager is very easy to use and totally reliable.  I also have the Password Manager app on my own mobile phone, a Samsung Galaxy A20e running Android 11.  It syncs the password store with the other devices perfectly and when I login to a site it offers the autofill option for ESET Password Manager just as it should.

I have the same EPM app setup on my wife's mobile, an older Samsung Galaxy J3 running Android 9.  Password Manager syncs up correctly and shows the same list of sites and login details but it absolutely refuses to allow any autofill functionality.  The option for Autofill in each account in the Manager does not even show the Autofill option to tick.  (I know this is normal.)  In the Android system I have checked and both phones are showing System Autofill is enabled with EPM as the chosen manager.

On my wife's phone I can access the login details in Password Manager itself but I then have to Copy/Paste them across manually.  In my own phone, when I login to a site, entering in the Username field brings up the option to "Auto fill with ESET Password manager" which when selected then enters the correct password.

Why is autofill not offering me the Eset Password Manager details in my wife's mobile  as it does on my own?

Link to comment
Share on other sites

  • Administrators
  • Solution

Please raise a support ticket using the built-in form and let logs to be submitted to ESET for perusal.

Link to comment
Share on other sites

Thanks Marcos.  I have done this now and ESET have responded immediately.  We are talking and swapping info at the moment.  I will make sure to come and report on any advice they give and whether we find an answer which might help others.

Link to comment
Share on other sites

Ok we have a fair bit to update here to round off.  The ESET team have spent a lot of time talking to me, both support and development teams, with screenshots sent and acknowledged and I am very grateful for their help and advice.  Their support has always been second to none in my experience.

One thing is becoming clear, this is most likely not an ESET programming issue.  I now have the problem Samsung mobile (on Android 9 and too old to update further), a second Samsung mobile and a Samsung tablet (both on Android 11 and also fixed there), all running ESET Mobile Security alongside ESET Password Manager and using Chrome.  The second mobile and the tablet work flawlessly.  The older Android 9 mobile refuses to co-operate.  We can't expect ESET to spend valuable development time chasing a problem which is so vaporous and not of their own making and I am happy with that.  Thanks to the support team for their attention.

It is now clear that there are areas of overlap with Android/Google/Samsung/ESET settings which may impact on each other.  For example:

Autofill is enabled in both Android and Google Chrome.  Does Google's setting only apply to their own Chrome Password Manager or does it impact on other third party managers too?  Do they clash?  Does one take precedence and override the other in either enabling or disabling?

And the default Password Manager has to be defined in Android Settings -> General Management -> Autofill Service, which it is to ESET in all three machines.  However in Apps -> ESET Password Manager -> Defaults, it still shows as 'Not Set' and any selectable options to set it there are greyed out!

There are far too many external settings to get right in order to let Chrome use EPM as its default Autofill app and I seem to be missing something somewhere.  Believe me I've crawled all over all three units to find clashes in their settings and can't find anything which is obvious.  Does anyone have any experience of this problem, or can you suggest anything to try?

Now to the workaround solution.  I installed Firefox on the problem mobile just to check the breadth of the problem and, whaddya know, it worked out of the box!  So the answer seems to be clear.  If Chrome gives anyone else this sort of problem, (and I can't believe I or my mobile or its settings are in any way unique), then simply ditch Chrome!  It only seems to be with Android 9 so I would guess it won't be a terribly common occurrence if it ever appears again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...