Jump to content

ESET Repository displays NO DATA AVAILABLE.


NumberFive
 Share

Recommended Posts

Good morning.
I was trying to update several instalations of ESET Endpoint security by creating a new install task with the latest ESET release.
But I'm not able to do so, because the repository list is empty and displays the message NO DATA AVAILABLE.
Tried different browsers, tried restarting the ERA server.
No luck.
The hxxp://repository.eset.com/v1/info.meta  link does prompt for the file download (so I assume there's a connection being made).
We're also not using any proxies..
Tried changing the repository path from AUTOSELECT to the repository path, but no luck.

Any ideas?

--/--

Edit: Read that a few months back there was a downtime for the repository servers, can anyone confirm if that's the case or not?

We're located in EUROPE (West).

Edited by NumberFive
Link to comment
Share on other sites

  • Administrators

Please carry on as follows:

1, Temporarily set Debug verbosity for trace logging in the ESMC Server setup:
image.png

2, Start logging with Wireshark

3, Change the repository to any address (may be a non-existent)

4, Change the repository to Autoselect (this will enforce a connection to the repository).

5, Wait a few seconds, then stop logging in Wireshark.

6, Save and compress the Wireshark log and upload it here along with the trace log.

Link to comment
Share on other sites

  • ESET Staff
5 hours ago, NumberFive said:

Wireshark log is here...

Not sure if this is what you want.
These were under /var/log/eset/RemoteAdministrator/Server

Wiresharklog.zip

Logs.zip 1016.06 kB · 0 downloads

In trace logs, relevant error is:

2019-07-08 15:55:48 Error: CRepositoryModule [Thread 7f44257e2700]: GetFile: Host 'repository.eset.com' not found [error code: 20002]

2019-07-08 15:55:48 Error: CRepositoryModule [Thread 7f44257e2700]: GetFile: Host 'repository.eset.com' not found [error code: 20002]

which indicates some kind of network problem. Most probably outside network was unreachable at the moment of connection.

Unfortunately wireshark log did not capture any attempt to connect to repository.eset.com, not there is any DNS request with this hostname. I think it it because repository synchronization is performed every 60 minutes and it was not executed during wireshark capturing. Repository synchronization is performed each time it's configuration is changed, which might be way how to force synchronization and capture it.

In case connection works from browser, it might be related to HTTP proxy or firewall configuration. In case proxy is used, could you verify it works correctly? Is there any firewall that could possibly block connections?

Link to comment
Share on other sites

Good morning MartinK.

There is no PROXY in use.
And the firewall is not set to block connections.

---//---

Ok, MartinK, I checked the firewalls settings, everything seems OK, BUT, when we installed the firewall we forgot to change the gateway on the ERA server..

After changing that and the DNS everything seems to be OK.

Sorry for wasting your time..

Thx alot for the help, keep up the good work..

Edited by NumberFive
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...