Jump to content

Delayed Launch of NOD32 Antivirus v9.0.349.0 In Windows 7 64 Bit

Go to solution Solved by spotter4me,

Recommended Posts



Recently, I have noticed that the NOD32 system tray icon does not appear at boot up even though it is set to do so. After several minutes, it finally launches and the NOD32 program window strangely pops up on my monitor. In the past, when things were working correctly, the Icon would just appear at boot up and that was it. No program window would launch unless I clicked on the icon in the system tray. Furthermore, a  Windows error reporting icon on the system tray tells me that the program is not running after boot up. Once the NOD32 icon appears on the system tray and the NOD32 program window pops up that message goes away.


It appears something is now conflicting with the start-up of NOD32 for several minutes anyway. Not sure what this could be at this point.


Anyone have any ideas?  I do not like being unprotected for several minutes after each boot up.





Edited by spotter4me
Link to comment
Share on other sites

  • ESET Staff

Hi Paul,


Before starting with some "step by step" digging I suggest you try the first thing, Uninstall/Install again.



  • uninstall using the Uninstaller of ESET in the program list. There is no uninstallers AFAIK.

After the uninstall, reboot, clean temp folders, and install again.

The normal way is, after the installation finish, the ESET logo with the android will appears. When ask

for activation, reboot.

After that activate, let him update the database.

Shutdown, wait some minutes and start the pc.


Lets us know the results. :)

Link to comment
Share on other sites

  • Administrators

I'd check if full or at least mini application memory dumps are selected under Tools -> Diagnostics. If so, check the Diagnostics folder if there are any dumps. If the folder is basically empty, egui is not crashing and it merely takes longer for ekrn to start it for whatever reason. In older versions, egui.exe was started by Windows as it was registered in the Run key.

Link to comment
Share on other sites

  • Solution

Hello Gonzalo and Marcos:


I resovled the issue. I uninstalled NOD32 and manually deleted all Eset files on my drive. I also maually went through the Registry and deleted all Eset keys. Interestingly, when I was trying to deleted all Eset files on my drive I could not delete some files. Windows said the files could not be deleted and were corrupted. So I ran Checkdisk and many repairs were implemented on my C drive. I then reininstalled NOD32 v349 and the taskbat icon appeared at boot up. No delays. Everything runs fine now. It looks like to me that NOD32 was trying to access corrupt files during boot and could not, thus causing the delay in the boot up of  NOD32.


One thing I also noted during my scan through the Registry was that I noticed that there was a NOD32 key in there soemwhere that had a "HOLD" appended to the file path to the egui.exe file. Is that key a normal part of the program or could that have been part of the issue?


Many thanks to the both of you for your help.


This issue can be marked as solved.



Edited by spotter4me
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...