Jump to content

The ESET Service service is marked as an interactive service.


Recommended Posts

We are migrating from ERA V5.1.38.0 and EMSX V4.5.10015.0.  The new virtual machines are Windows 2012, when installing EMSX on the client exchange servers this Event ID appeared: 

 

 

Log Name:      System

Source:        Service Control Manager

Date:          1/22/2016 1:47:49 PM

Event ID:      7030

Task Category: None

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      xxxxxxxxxxxx.xxxxxxxx.xxx

Description:

The ESET Service service is marked as an interactive service.  However, the system is configured to not allow interactive services.  This service may not function properly.

 

 

It appears that the ESET Service is allowed to interact with the desktop, but this is also a security hole. 

 

"In most cases, it is recommended that you not change the Allow service to interact with desktop setting. If you allow the service to interact with the desktop, any information that the service displays on the desktop will also be displayed on an interactive user's desktop. A malicious user could then take control of the service or attack it from the interactive desktop."

 

My security team is to too happy about this.  Access is denied when I try to uncheck the box so I can't make that change. 

 

So I am hoping the you can answer these questions:

 

If I am not too concerned about pop up messages can this be turned off somehow?  

 

I see the registry setting (NoInteractiveServices is set to REG_DWORD (0))

that controls this has been changed, is that done during the installation of  EMSX?

 

Is there a best practices article on how to configure the ESET Service so that is does not interact with the desktop? 

 

Thanks, Beekeeper5

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...