Jump to content

Is eraserver still using libssl1.1 in ubuntu 22.04.3?

Go to solution Solved by MartinK,

Recommended Posts

Hi there!

i Have an interesting issue when i try updating my components on my server.

First i want to update my mysql server from 8.0.33 to 8.0.36 but it have conflicts, so i need to remove the community edition then reinstall it.

If im done with it the package manager remove the unused packages whitch is the libssl1.1 and the mysql-community-client plugins.

When it occurs, the eraserver can't be started cause it can't find the libmyodbc8w.so , so it can't connect to the mysql server.

I tried updating the odbc driver to pair with the mysql version (the current version is 8.0.17) reinstall the libssl1.1 from dpgk but nothing changes. lastly i rollbacked my whole server to before i updated my mysql server.

thats happened with the version, now im updated to without any issue but im confused if i shoud update my components or leave it as it is

My guess is the eraserver still using the libssl1.1 not libssl3

Please confirm it for me it still occurs in the 11. versions or not or im missing something.

The following packages have unfulfilled dependencies:
 mysql-common : Conflicts with: mysql-client-8.0 but only 8.0.36-0ubuntu0.22.04.1 can be installed
                Conflicts with: mysql-client-core-8.0 but only 8.0.36-0ubuntu0.22.04.1 can be installed
 mysql-server : Depends on: mysql-community-server (= 8.0.33-1ubuntu20.04) but it is not marked for installation

Thank you.



Link to comment
Share on other sites

  • ESET Staff
  • Solution

As per kb8515 ESET PROTECT 11.0+ should be capable of running on OpenSSL3+ based linux distributions, but there are certain limitations in certificates is is actually using, especially in case older operating systems are being managed in the network.

As you mentioned, there is a problem with MySQL ODBC driver, which is probably still using using older openssl or other dependencies are missing (might be verified for example using ldd command line utility). If this is the case, I would recommend to "consult" with documentation of MySQL ODBC driver or linux distribution, depending of the source of the used ODBC driver. It is possible later version of ODBC driver will be required to be used, or dependency will have to be resolved otherwise.

Link to comment
Share on other sites

Okay, thank you for your answer i will halt my updates for a little time to avoid unnecessary issues.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...