Archived

This topic is now archived and is closed to further replies.

jasonchan121

ESET Mail Security compatibility

Recommended Posts

Hello,

      The requirements for the ESET Mail Security for Linux are as follows (as per the manual located at hxxp://download.eset.com/manuals/eset_ems_4_userguide_enu.pdf)

 

The following hardware requirements must be met before the installation process in order to run ESET Mail Security properly:
*250MB of hard-disk space
*256MB of RAM

*glibc 2.3.6 or higher
*2.6.x Linux OS kernel versions

ESET Mail Security should work on most recent and frequently used open-source Linux distributions if the above criteria are met.

 

The following Linux distributions (x86/x64) are officially supported:
*Red Hat Enterprise Linux
*SUSE Linux Enterprise
*ESET Mail Security will also run on the following operating systems (but only x86, 32-bit):
*NetBSD 4
*FreeBSD 6, 7, 8 and 9
*SUN Solaris 10

 

Some other items that your mail solution must also include are as follows:

 

MTA - Mail Transport Agent
A program (e.g., sendmail, postfix, qmail, exim, etc.) that enables the transfer of email messages between local and remote
domains.

MDA - Mail Delivery Agent
A program (e.g., maildrop, procmail, deliver, local.mail, etc.) that enables the delivery of locally addressed email messages into
particular mailboxes.

MUA - Mail User Agent
A program (e.g., Microsoft Outlook, Mozilla Thunderbird, Eudora, etc.) that provides access to and management of email
messages, such as reading, composing, printing, etc.

MAILBOX
A file or file structure on a disk serving as the storage space for email messages. The email server receives data communication using SMTP (Simple Mail Transfer Protocol) communication. The received message is transferred by MTA either to another remote email messaging system or is delivered using local MDA into a particular MAILBOX. In most cases, each local network user owns a MAILBOX located on the server. Note that it is the
responsibility of the user’s local MUA to provide the function of downloading and correctly interpreting the message at the user’s computer. When retrieving data from MAILBOX, the MUA typically uses POP3 (Post Office Protocol) or IMAP (Internet Message Access Protocol) to communicate with the MTA. The SMTP protocol is used to send data to the Internet. The ESETS operating principle is based on data communication interception and scanning at the various phases of its transfer.

The interception locations are marked in figure 5-1 by symbols S1, S2, S3 and S4.
S1 - Bi-directional email message scanning, i.e. content filtering in MTA.
S2 - Scanning of inbound email messages, i.e. messages with a target address which is located inside the local domain.
S3 - Scanning of outbound email messages, i.e. messages bound to a remote Internet domain.
S4 - Scanning of email messages being downloaded from POP3/IMAP server.

 

As long as the Zimbra system contains all of these following requirements, it should integrate and allow antispam protection for your mail clients (Zimbra utilizes sendmail, so that is a plus in this scenario)

 

-Michael A.

Share this post


Link to post
Share on other sites

Hello, the Solaris build doesn't work with esets_cli. We've tried with the same config, same license on Linux and it works. On Solaris (both 10 & 11, it shows:

 

/opt/esets/bin/esets_cli Photo1588.zip
error[4eda0000]: Cannot get setup from daemon: Daemon closed connection
 
MTA agent doesn't get started either.

Share this post


Link to post
Share on other sites

Hey there,

 

I am getting the following errors on a mail server with Zimbra (Ubutu 14) when I run esets_setup :

 

****************************

Available ESETS installations/uninstallations:

1) MTA

2) POP3

3) IMAP

4) SMTP

5) quit

Your selection (1-5): 1

*****************************

 

(1)

error[292d0000]: ESETS to MTA install/uninstall: No file master.cf in /etc/postfix:/usr/local/etc/postfix:/etc/opt/csw/postfix

Installation failed with code 1

 

(2)

error[63b00000]: ESETS to MTA install/uninstall: No file main.cf in /etc/postfix

Installation failed with code 1

 

(3)

error[137d0000]: ESETS to MTA install/uninstall: No file cswpostfix in /etc/init.d: /opt/csw/etc/init.d: /etc/opt/csw/init.d: /etc/rc.d: /usr/local/etc/rc.d

Installation failed with code 1

 

# locate master.cf

/opt/zimbra/postfix-2.11.1.2z/conf/master.cf

/opt/zimbra/postfix-2.11.1.2z/conf/master.cf.in

/opt/zimbra/postfix-2.11.1.2z/libexec/master.cf

 

Is there a way to get the two to integrate without error?

 

Donnyblu

 

Ps. POP3 and SMTP do not integrate either.

Share this post


Link to post
Share on other sites

The same my issue, but maybe this sub forum is unnoticed.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.