Jump to content

Issue with Eset and Firefox

Recommended Posts

Hello all,

I have installed a 30 day trial of Eset antivirus and am experiencing the following issue.

I have enabled DNS over HTTPS using Cloudflare in Firefox settings. Most sites open fine but some site refuse to open since installing Eset.

Firefox shows the following error: Secure Connection Failed

An error occurred during a connection to www.kraken.com. SSL_ERROR_MISSING_ESNI_EXTENSION"

If I disable HTTPS scanning in Eset all sites open fine again. One site for example that refuses to load with HTTPS scanning enabled is hxxp://kraken.com

I'm running the latest version of windows 10 Home edition, Firefox 83, Eset

Anybody else able to confirm this issue?

Link to post
Share on other sites
42 minutes ago, itman said:

Appears you enabled; i.e. set to true, this setting:


This feature in Firefox is experimental and always has been buggy. Set it back to the default false setting and you will have no issues with Eset in FireFox DoH mode. I can open this web site, hxxp://kraken.com/ , w/o issue.

Thank you, I forgot mentioning that I had enabled this settings. Disabling encrypted SNI indeed fixes this problem.

I think I enabled this setting around 2 years ago and personally never encountered any problems. During this time I have had both Kaspersky and Bitdefender installed with HTTPS scanning enabled without issue.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...